Open Bug 143489 Opened 19 years ago Updated 10 years ago

Go Next Unread thread and collapse read thread

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

People

(Reporter: phil, Unassigned)

References

(Blocks 1 open bug)

Details

(Windows 2K, Mozilla 1.0 rc1, Gecko 20020417)
Steps:
1. Open Messenger 
2. Select a newsgroup (one with some unread messages and threads)
3. Select View | messages | All
4. In the Thread pane, have the messages threaded (click on the thread icon)
5. Expand a thread and select an unread message 
6. Select Go | Next | Unread Thread (the keyboard shortcut is "t")

Actual result:
When the messages are displayed as threads, this choice will mark all the
messages in the curent thread as read, and will select the next unread message
in the following thread. 

Expected result:
An improvement would be to have the "all read thread" automatically collapsed
before the next unread message is selected. A possible implementation could be
to use "SHIFT + t" to do that.

see also bug 59263 and bug 66466 to be sure both are compatible (SHIFT + t would
collapse the thread/newsgroup or folder/account when they don't contain anymore
unread article, and move the selection on the next message or article unread in a 
thread/newsgroup or folder/account)
I think we have an old bug about this.
QA Contact: olgam → laurel
Perhaps, but I've checked before reporting... and couldn't find it ;-) 

What there is however, is a problem with the marking of read articles/messages.
Therefore this enh. ticket probably depends heavily on resolution of bug 108906
"Threads with only read messages still appear in "Threads with unread" mode".
and bug 64476
"threads with unread returns false positives"

For the shortcuts parts, see bug 109744 
"[RFE] option to collapse/expand subthreads"
And for the Bold/Underline text of an unread thread see bug 74357
"text styles for collapsed threads with unread children"

That's what I've found so far...
I too have found no dupes, thus conmfirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Blocks: 236849
Product: Browser → Seamonkey
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: laurel → message-display
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → EXPIRED
Valid RFE.
Status: RESOLVED → REOPENED
Ever confirmed: true
Hardware: x86 → All
Resolution: EXPIRED → ---
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.