Portable & Threadsafe NON-cryptographic Pseudo Random Number Generation API

NEW
Assigned to

Status

NSPR
NSPR
--
enhancement
16 years ago
7 years ago

People

(Reporter: kaie, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Currently, NSPR does not provide functions to generate pseudo random numbers,
that use the thread safe equivalent available on each platform, as it should be
used in a multithreaded application - like rand_r on Linux.

I think it would be good to have support for at least:
- rand
- srand
(Reporter)

Updated

16 years ago
Blocks: 143492
(Assignee)

Updated

16 years ago
Severity: normal → enhancement

Comment 1

12 years ago
No use keeping two bugs on the same topic: threadsafe number generation (in NSPR or elsewhere...)

*** This bug has been marked as a duplicate of 143492 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
No longer blocks: 143492
(Assignee)

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

12 years ago
Blocks: 143492
QA Contact: wtchang → nspr
This bug asks NSPR to provide a new API. 
There are other bugs (such as bug 143492) that ask other mozilla products 
to use this NSPR API, once it is developed.  This bug is NOT a duplicate of
those others, and they are NOT duplicates of this bug.
Status: REOPENED → NEW
Summary: Portable & Threadsafe Pseudo Random Number Generation → Portable & Threadsafe NON-cryptographic Pseudo Random Number Generation API
You need to log in before you can comment on or make changes to this bug.