Translation error in New Tab

RESOLVED FIXED in Firefox 59

Status

()

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: flod, Unassigned)

Tracking

59 Branch
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59+ fixed, firefox60 fixed)

Details

User Story

https://github.com/mozilla/activity-stream/compare/firefox-59b10...firefox-59b11

Attachments

(3 attachments)

Reporter

Description

Last year
Posted image bug.png
This was reported via Twitter
https://twitter.com/PitWenkin/status/959088685231812609/photo/1

Top Sites = Meistbesuchte Seiten, but also Wichtige Seiten

Highlights = Wichtigste Seiten, but also Überblick
Reporter

Comment 1

Last year
@Michael or Sebastian
Can one of you take a look at this bug? 

I'm not sure if we can get an update for Activity Stream uplifted to Beta, but the chances get lower as we move into the middle of the Beta cycle.
Flags: needinfo?(coce)
Flags: needinfo?(aryx.bugmail)

Comment 2

Last year
mozilla-beta 59 is still `EARLY_BETA` until next Tuesday 13th, so we can try requesting uplift with the strings before then

Comment 3

Last year
[Tracking Requested - why for this release]: Differently translated strings for german (and updating other strings) for 59
Flags: needinfo?(coce)
Update these two strings. The only way to test this would be to alter the strings in the mozilla repository at browser/extensions/activity-stream/prerendered/locales/de/activity-stream-strings.js - I skipped that because the new ones should fit.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(aryx.bugmail)
Resolution: --- → FIXED

Updated

Last year
Attachment #8951736 - Attachment description: looks good on nightly 60 → looks good on local 60
Early beta ended around beta 7 --  next Monday will be beta 11. 
But you can still request uplift.

Updated

Last year
User Story: (updated)
Depends on: 1437213
Comment hidden (mozreview-request)

Comment 8

Last year
mozreview-review
Comment on attachment 8951802 [details]
Bug 1435172 - Translation error in New Tab.

https://reviewboard.mozilla.org/r/221080/#review227024

r=dmose
Attachment #8951802 - Flags: review?(dmose) → review+

Updated

Last year
Component: de / German → Activity Streams: Newtab
Product: Mozilla Localizations → Firefox
Target Milestone: --- → Firefox 59
Version: unspecified → 59 Branch

Comment 9

Last year
Comment on attachment 8951802 [details]
Bug 1435172 - Translation error in New Tab.

Approval Request Comment
[Feature/Bug causing the regression]: Activity Stream
[User impact if declined]: Translation inconsistency for de and wrong strings for other locales: bg, cs, eo, ff, gd, pl, ro, ru, te, uz, vi
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Not really
[Why is the change risky/not risky?]: Strings only change
[String changes made/needed]: Yes, these are the translated strings from pontoon. (flod from previous uplifts: "Note that this patch doesn't require l10n=XXX in the commit message, it doesn't touch .properties files, and localization happens outside of m-c. It's good to uplift from a l10n point of view.")
Attachment #8951802 - Flags: approval-mozilla-beta?
Comment on attachment 8951802 [details]
Bug 1435172 - Translation error in New Tab.

AS translation updates for 59beta
Attachment #8951802 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Updated

Last year
User Story: (updated)
You need to log in before you can comment on or make changes to this bug.