Closed Bug 1435193 Opened 3 years ago Closed 3 years ago

First day of the week is reset to Sunday after every Thunderbird restart

Categories

(Calendar :: Preferences, defect)

Lightning 6.0
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1473294

People

(Reporter: benoit.leseul, Unassigned)

References

Details

Lightning 6.0b on Thunderbird 58.0b3 (Windows 10, 32-bit Thunderbird beta)

I've set up "Monday" as first day of the week as is usual in most European countries, but that setting is lost after every Thunderbird restart. The first day is back to Sunday in the Calendar view and in the preferences window. 

Other preferences in the same panel like workweek days are remembered fine.

Might be related to bug #1230124 but worse.
On which locale are you? And are you using your profile on different TB versions/locales concurrently (then it would be bug 1230124)?

Note to self: The first day in the week is a locale depending pref, maybe we have a race condition in the fix for bug 1414398 when loading lightning.js and lightning-l10n.js
Flags: needinfo?(benoit.leseul)
Sorry I thought I mentioned it in the report. 

It's the French version (fr) and I use that one exclusively. I made sure to relaunch the application several times to be sure no automatic update was occurring. 

The problem doesn't occur in Thunderbird 52 (which I tried on another machine with another profile). Is there an older beta I could try to check if it was indeed caused by the fix you mention?
Flags: needinfo?(benoit.leseul)
Philipp, this seems to me to be a fallout of the TB extension pref loader - do we handle l10n pref files properly there?
Flags: needinfo?(philipp)
I'm pretty sure we don't handle l10n prefs there, we would need to add support.
Flags: needinfo?(philipp)
Depends on: 1473294
I can confirm this on Czech TB 60 with Lightning 6.2. On every restart there is Sunday set to be the first day of the week despite my setting Monday to be the first.
Duplicate of this bug: 1481469
Same for me on a German Thunderbid 60 - was no problem with the previous version
This will be fixed for TB60 with bug 1473294.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1473294
You need to log in before you can comment on or make changes to this bug.