Closed Bug 1435346 Opened 4 years ago Closed 4 years ago

getASTSource unsupported computed MemberExpression

Categories

(Firefox Build System :: Lint and Formatting, defect)

3 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1435342

People

(Reporter: mccr8, Unassigned)

Details

I started seeing this error locally in the last week or so. I'm not sure what it means.

amccreight@bangles:~/mc$ ./mach eslint --setup
Installing eslint for mach using "/usr/bin/npm install --loglevel=error"...

ESLint and approved plugins installed successfully!

NOTE: Your local eslint binary is at /media/ssd/mc/node_modules/.bin/eslint

✖ 0 problems (0 errors, 0 warnings)
amccreight@bangles:~/mc$ ./mach eslint testing/talos/
An error occurred running eslint. Please check the following error messages:

getASTSource unsupported computed MemberExpression in /media/ssd/mc/testing/talos/talos/tests/tp5n/56.com/s1.56img.com/js/jquery/jquery-1.4.2.min.js
Error: getASTSource unsupported computed MemberExpression in /media/ssd/mc/testing/talos/talos/tests/tp5n/56.com/s1.56img.com/js/jquery/jquery-1.4.2.min.js
    at Object.getASTSource (/media/ssd/mc/node_modules/eslint-plugin-mozilla/lib/helpers.js:94:17)
    at CallExpression (/media/ssd/mc/node_modules/eslint-plugin-mozilla/lib/rules/avoid-removeChild.js:37:19)
    at listeners.(anonymous function).forEach.listener (/media/ssd/mc/node_modules/eslint/lib/util/safe-emitter.js:47:58)
    at Array.forEach (native)
    at Object.emit (/media/ssd/mc/node_modules/eslint/lib/util/safe-emitter.js:47:38)
    at NodeEventGenerator.applySelector (/media/ssd/mc/node_modules/eslint/lib/util/node-event-generator.js:251:26)
    at NodeEventGenerator.applySelectors (/media/ssd/mc/node_modules/eslint/lib/util/node-event-generator.js:280:22)
    at NodeEventGenerator.enterNode (/media/ssd/mc/node_modules/eslint/lib/util/node-event-generator.js:294:14)
    at CodePathAnalyzer.enterNode (/media/ssd/mc/node_modules/eslint/lib/code-path-analysis/code-path-analyzer.js:606:23)
    at Traverser.enter (/media/ssd/mc/node_modules/eslint/lib/linter.js:967:32)
A failure occurred in the eslint linter.
✖ 1 problem (0 errors, 0 warnings, 1 failure)
I can't reproduce, what platform are you on?

Mark, any chance you've seen this error before?
Flags: needinfo?(standard8)
I'm on Linux. I'm using some kind of Ubuntu LTS, I think, so maybe something that gets run as part of this is an out of date version that just started to break.
If this doesn't ring any bells, I can try bisecting it.
According to bug 1435342, Talos is extracting the tp5n dataset into the source tree. ESLint doesn't expect this, so tries to lint it, which I guess is then blowing it up.

We'll have to ignore it, altohugh really Talos shouldn't be extracting into the source tree.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(standard8)
Resolution: --- → DUPLICATE
Duplicate of bug: 1435342
Ah hah, that's why I first started seeing this recently.
Product: Testing → Firefox Build System
Version: Version 3 → 3 Branch
You need to log in before you can comment on or make changes to this bug.