Closed Bug 1435359 Opened 4 years ago Closed 4 years ago

Nightly DMG is missing Finder background

Categories

(Firefox :: Theme, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: Dolske, Assigned: shorlander)

References

Details

Attachments

(1 file)

The Nightly DMG download is missing a background in its Finder / folder view. There's just a Nightly icon and App folder shortcut showing, without the background grouping/arrow to guide the user to drag Nightly to install it.

Almost certainly caused by bug 1404796, and same issue/fix as bug 1399731.

Stephen, you want to regenerate the DSStore again? Hopefully we're done renaming things. :)
Flags: needinfo?(shorlander)
Priority: -- → P3
Update the Firefox Nightly DMG to pick up the background image again.
Flags: needinfo?(shorlander)
For future reference this is process I used for this:

    # Custom Disk Image Background / Window Creation
     
    1.  Update mozilla-central
    2.  Check to make sure you are using the right brand directory:
        * Official:  ac_add_options --with-branding=browser/branding/official
        * Dev Tools: ac_add_options --with-branding=browser/branding/aurora
        * Nightly:   ac_add_options --with-branding=browser/branding/nightly
    3.  Clobber your build: ./mach clobber
    4.  Build Firefox: ./mach build
    5.  Build Firefox packaging: ./mach package
    6.  Find the resulting DMG e.g.: /Users/shorlander/Mercurial/mozilla-central/obj-x86_64-apple-darwin17.4.0/dist/firefox-60.0a1.en-US.mac.dmg
    7.  Copy the DMG to a new place you can work on it e.g.: ~/Desktop/Firefox DMG Creation/firefox-60.0a1.en-US.mac.dmg
    8.  Open the Disk Utility application
    9.  From the Menu Bar choose "New Image --> Blank Image…"
        * Save as: <Unique File Name.dmg>
          - Needs to be unique because there appears to be some kind of caching going on that messes with the modifications
        * Name: <The Exact Name of Your Disk Image>
          - E.g. "Firefox Nightly"
        * Size: <Big Enough to Fit the Firefox application, background image, and Application Folder alias>
          - I used 500 MB
        * Format: Mac OS Extended (Journaled)
          - This probably doesn't really matter
        * Encryption: None
        * Partitions: Single partition - GUID Partition Map
        * Image Format: **read/write disk image**
    10. Open your new DMG
    11. Copy the Firefox application to the new Disk Image from the old Disk Image
    12. Create a new alias to the Applications folder
        * Or copy it from the old Disk Image
    13. Create a new hidden folder called ".background"
        * mkdir /Volumes/Firefox\ Nightly/.background
    14. Copy the background image you want to use to ".background"
         * mv ~/Desktop/background.png /Volumes/Firefox\ Nightly/.background/
    15. Arrange the open DMG window the way you want:
        * Size
        * Layout
        * Viewable Parts
        * Etc.
    16. In a new Finder window "Menu Bar --> Go --> Go to Folder… ⇧⌘ G " and open /Volumes/Firefox Nightly/.background
    17. Open the View Options window with ⌘ J
    18. Choose the background.png from /Volumes/Firefox\ Nightly/.background/background.png
    19. Eject your DMG
    20. Go back to Disk Utility
    21. From the Menu Bar choose "Image --> Convert…"
        * Select the DMG you have been working on
        * Encryption: None
        * Image Format: **compressed**
    22. Open you converted DMG and make sure it worked
    23. Copy the .DS_Store file to the right branding directory in mozilla-central
        * cp /Volumes/Firefox\ Nightly/.DS_Store ~/Mercurial/mozilla-central/browser/branding/nightly/dsstore
    24. Clobber, build and package again
    25. Test that it works
    26. Done!
Comment on attachment 8951066 [details] [diff] [review]
update-nightly-dsstore.patch

rs=me, and thanks for documenting how to do this.
Attachment #8951066 - Flags: review?(dolske) → review+
(In reply to Justin Dolske [:Dolske] from comment #3)
> Comment on attachment 8951066 [details] [diff] [review]
> update-nightly-dsstore.patch
> 
> rs=me, and thanks for documenting how to do this.

I should note that if that process seems ridiculous, that's because it is ;) But also that in the past I have tried various tools to streamline this process and none of them worked quite right.
I assume we want to check this in.
Keywords: checkin-needed
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7433031c9274
Update Firefox Nightly DMG .DS_Store file to use background image. r=Dolske
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7433031c9274
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Stephen, when I read comment #2, I would like to send you a HUGE thanks :)
(I just noticed that bug, sorry about that :(
You need to log in before you can comment on or make changes to this bug.