Closed Bug 1435415 Opened 3 years ago Closed 3 years ago

regression: Youtube's channel headers are broken

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1435143
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled

People

(Reporter: jan, Assigned: gw)

References

(Blocks 1 open bug, )

Details

(Keywords: correctness, nightly-community)

Attachments

(2 files)

Attached video 2018-02-02_22-45-17.mp4
Scroll up and down to check if the channel header is broken.
mozregression --good 2018-01-30 --bad 2018-02-02 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://www.youtube.com/user/failarmy/videos"
> 7:17.29 INFO: Last good revision: c9c4506e63009d9a5f4da3ef6d5e88fa529b4f75
> 7:17.29 INFO: First bad revision: 3940b5d8f13529b17acfba25fa8e1d1d179628d0
> 7:17.29 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c9c4506e63009d9a5f4da3ef6d5e88fa529b4f75&tochange=3940b5d8f13529b17acfba25fa8e1d1d179628d0

> 3940b5d8f135	Martin Roinson — Bug 1434288 - Update gecko for API changes in WR PR 2315. r=kats
> e99f6587c86e	Kartikaya Gupta — Bug 1434288 - Update webrender to commit e772c3cb8ea0a35e6477e9dc8dd2144e2de87b56. r=jrmuizel

-----

> WR @ b6e69a8efbcd8dc3e0c0a8a9925e6a9355635de3
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=9ea0e50f426552229ab5746ed3f5ab1c9ebf0561
mozregression --repo try --launch 9ea0e50f426552229ab5746ed3f5ab1c9ebf0561 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://www.youtube.com/user/failarmy/videos"
-> good

> WR @ 87c6a6ba7e75d8ed0b2ddeeb5fa4e363482f7f86
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=7801945b00e7eac75e8bdf9d64869a9c284599de
mozregression --repo try --launch 7801945b00e7eac75e8bdf9d64869a9c284599de --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://www.youtube.com/user/failarmy/videos"
-> good

> WR @ e772c3cb8ea0a35e6477e9dc8dd2144e2de87b56, with the fixes
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=62ab4844535a8ae2194ee6b7e43c1f9f05bb1511
mozregression --repo try --launch 62ab4844535a8ae2194ee6b7e43c1f9f05bb1511 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://www.youtube.com/user/failarmy/videos"
-> bad

https://github.com/servo/webrender/compare/87c6a6ba7e75d8ed0b2ddeeb5fa4e363482f7f86...e772c3cb8ea0a35e6477e9dc8dd2144e2de87b56
Nightly 60 x64 20180202102708 de_DE @ Debian Testing (KDE, Radeon RX480)
fresh profile: gfx.webrender.all

It looks a bit different when using the dark theme.
Assignee: nobody → gwatson
Priority: -- → P1
See Also: → 1435143
Fixed in the try build from bug 1435143 comment 7.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
See Also: 1435143
Duplicate of bug: 1435143
This being fixed with a PR - is there a Gecko side reftest that we can add that catches this problem?
You need to log in before you can comment on or make changes to this bug.