Intermittent w3c-css/submitted/test-template-001.xht == w3c-css/submitted/references/test-template-001.xht | application crashed [@ mozilla::image::Downscaler::Downscaler]

RESOLVED FIXED in Firefox 60

Status

()

defect
P5
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: aosmond)

Tracking

({crash, intermittent-failure})

unspecified
mozilla60
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 wontfix, firefox60 fixed)

Details

(crash signature)

Attachments

(1 attachment)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=160139385&repo=mozilla-central

https://queue.taskcluster.net/v1/task/Zkxi9RvxS5u84kr60XIRPA/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/Zkxi9RvxS5u84kr60XIRPA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

[task 2018-02-02T20:35:07.544Z] 20:35:07     INFO -  REFTEST TEST-START | http://10.0.2.2:8888/tests/layout/reftests/w3c-css/submitted/test-template-001.xht == http://10.0.2.2:8888/tests/layout/reftests/w3c-css/submitted/references/test-template-001.xht
[task 2018-02-02T20:35:07.544Z] 20:35:07     INFO -  REFTEST INFO | RESTORE PREFERENCE pref(image.downscale-during-decode.enabled,false)
[task 2018-02-02T20:35:07.545Z] 20:35:07     INFO -  REFTEST TEST-LOAD | http://10.0.2.2:8888/tests/layout/reftests/w3c-css/submitted/test-template-001.xht | 141 / 311 (45%)
[task 2018-02-02T20:35:39.566Z] 20:35:39     INFO -  INFO | automation.py | Application ran for: 0:29:11.407899
[task 2018-02-02T20:35:39.567Z] 20:35:39     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpgglIf5pidlog
[task 2018-02-02T20:35:40.664Z] 20:35:40     INFO -  REFTEST INFO | Copy/paste: /usr/local/bin/linux64-minidump_stackwalk /tmp/tmpoz21zD/36959e31-3443-5df1-1351-2e516ea6264d.dmp /builds/worker/workspace/build/symbols
[task 2018-02-02T20:35:50.085Z] 20:35:50     INFO -  REFTEST INFO | Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/36959e31-3443-5df1-1351-2e516ea6264d.dmp
[task 2018-02-02T20:35:50.085Z] 20:35:50     INFO -  REFTEST INFO | Saved app info as /builds/worker/workspace/build/blobber_upload_dir/36959e31-3443-5df1-1351-2e516ea6264d.extra
[task 2018-02-02T20:35:50.089Z] 20:35:50     INFO -  REFTEST PROCESS-CRASH | http://10.0.2.2:8888/tests/layout/reftests/w3c-css/submitted/test-template-001.xht == http://10.0.2.2:8888/tests/layout/reftests/w3c-css/submitted/references/test-template-001.xht | application crashed [@ mozilla::image::Downscaler::Downscaler]
[task 2018-02-02T20:35:50.089Z] 20:35:50     INFO -  Crash dump filename: /tmp/tmpoz21zD/36959e31-3443-5df1-1351-2e516ea6264d.dmp
[task 2018-02-02T20:35:50.089Z] 20:35:50     INFO -  Operating system: Android
[task 2018-02-02T20:35:50.090Z] 20:35:50     INFO -                    0.0.0 Linux 2.6.29-gea477bb #1 Wed Sep 26 11:04:45 PDT 2012 armv7l
[task 2018-02-02T20:35:50.090Z] 20:35:50     INFO -  CPU: arm
[task 2018-02-02T20:35:50.090Z] 20:35:50     INFO -       ARMv7 ARM Cortex-A8 features: swp,half,thumb,fastmult,vfpv2,edsp,neon,vfpv3
[task 2018-02-02T20:35:50.090Z] 20:35:50     INFO -       1 CPU
[task 2018-02-02T20:35:50.090Z] 20:35:50     INFO -  GPU: UNKNOWN
[task 2018-02-02T20:35:50.091Z] 20:35:50     INFO -  Crash reason:  SIGSEGV
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -  Crash address: 0x0
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -  Process uptime: not available
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -  Thread 45 (crashed)
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -   0  libxul.so!mozilla::image::Downscaler::Downscaler [Downscaler.cpp:5d6d869ec7becc99b8c3dc639fc52e49b1af3ef1 : 30 + 0x0]
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -       r0 = 0x000000cc    r1 = 0xd4f7cd15    r2 = 0x600cdb1e    r3 = 0x0000001f
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -       r4 = 0x0000001f    r5 = 0x00000000    r6 = 0x00000020    r7 = 0x560ff6d8
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -       r8 = 0x6a8ad90c    r9 = 0x6a8ad800   r10 = 0x00000020   r12 = 0x00000003
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -       fp = 0x0000000c    sp = 0x560ff6d0    lr = 0x5c8dd0f1    pc = 0x5d2e34e6
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -      Found by: given as instruction pointer in context
[task 2018-02-02T20:35:50.094Z] 20:35:50     INFO -   1  libxul.so!mozilla::Maybe<mozilla::image::Downscaler>::emplace<mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> &> [Maybe.h:5d6d869ec7becc99b8c3dc639fc52e49b1af3ef1 : 459 + 0x5]
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       r4 = 0x6a8ad808    r5 = 0x6a8ad90c    r6 = 0x00000020    r7 = 0x560ff6e8
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       r8 = 0x6a8ad90c    r9 = 0x6a8ad800   r10 = 0x00000020    fp = 0x0000000c
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       sp = 0x560ff6e0    lr = 0x5d2e2753    pc = 0x5d2e2753
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -      Found by: call frame info
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -   2  libxul.so!mozilla::image::Decoder::PostSize [Decoder.cpp:5d6d869ec7becc99b8c3dc639fc52e49b1af3ef1 : 431 + 0x3]
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       r4 = 0x6a8ad800    r5 = 0x00000020    r6 = 0x00000020    r7 = 0x560ff720
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       r8 = 0x6a8ad90c    r9 = 0x6a8ad800   r10 = 0x00000020    fp = 0x0000000c
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       sp = 0x560ff6f0    lr = 0x5d2e2609    pc = 0x5d2e2609
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -      Found by: call frame info
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -   3  libxul.so!mozilla::image::nsICODecoder::FinishDirEntry [nsICODecoder.cpp:5d6d869ec7becc99b8c3dc639fc52e49b1af3ef1 : 309 + 0x7]
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       r2 = 0x00000020    r3 = 0x00000000    r4 = 0x54962828    r5 = 0x54962828
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       r6 = 0x00000001    r7 = 0x560ff770    r8 = 0x6a8ada00    r9 = 0x6a8ad800
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -      r10 = 0x00000020    fp = 0x0000000c    sp = 0x560ff728    lr = 0x5d31463f
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       pc = 0x5d31463f
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -      Found by: call frame info
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -   4  libxul.so!<name omitted> [nsICODecoder.cpp:5d6d869ec7becc99b8c3dc639fc52e49b1af3ef1 : 690 + 0x3]
[task 2018-02-02T20:35:50.095Z] 20:35:50     INFO -       r4 = 0x55cea770    r5 = 0x6a8ad800    r6 = 0x6a8ad94c    r7 = 0x560ff790
[task 2018-02-02T20:35:50.096Z] 20:35:50     INFO -       r8 = 0x6a8ad94c    r9 = 0x560ff7e8   r10 = 0x560ff830    fp = 0x6a8ad884
[task 2018-02-02T20:35:50.096Z] 20:35:50     INFO -       sp = 0x560ff778    lr = 0x5d322979    pc = 0x5d322979
[task 2018-02-02T20:35:50.096Z] 20:35:50     INFO -      Found by: call frame info
[task 2018-02-02T20:35:50.096Z] 20:35:50     INFO -   5  libxul.so!mozilla::image::nsICODecoder::DoDecode [StreamingLexer.h:5d6d869ec7becc99b8c3dc639fc52e49b1af3ef1 : 649 + 0x3]
[task 2018-02-02T20:35:50.097Z] 20:35:50     INFO -       r0 = 0x560ff7e8    r1 = 0x560ff7b0    r2 = 0x00000002    r3 = 0x57d23016
[task 2018-02-02T20:35:50.097Z] 20:35:50     INFO -       r4 = 0x55cea770    r5 = 0x6a8ad800    r6 = 0x6a8ad94c    r7 = 0x560ff820
[task 2018-02-02T20:35:50.097Z] 20:35:50     INFO -       r8 = 0x6a8ad94c    r9 = 0x560ff7e8   r10 = 0x560ff830    fp = 0x6a8ad884
[task 2018-02-02T20:35:50.097Z] 20:35:50     INFO -       sp = 0x560ff798    lr = 0x5d31587d    pc = 0x5d31587d
[task 2018-02-02T20:35:50.098Z] 20:35:50     INFO -      Found by: call frame info
Component: Layout → ImageLib
Flags: needinfo?(aosmond)
Looks like the same reason as bug 1434935, so not introduced by what Andrew landed today.
(In reply to Timothy Nikkel (:tnikkel) from comment #2)
> Looks like the same reason as bug 1434935, so not introduced by what Andrew
> landed today.

Agreed. Given it is a live pref and can nominally change at any time, I think we can just take out the assert.
Flags: needinfo?(aosmond)
Assignee: nobody → aosmond
Status: NEW → ASSIGNED
Fix all the broken windows! :)
Attachment #8949519 - Flags: review?(tnikkel)
(In reply to Andrew Osmond [:aosmond] from comment #3)
> (In reply to Timothy Nikkel (:tnikkel) from comment #2)
> > Looks like the same reason as bug 1434935, so not introduced by what Andrew
> > landed today.
> 
> Agreed. Given it is a live pref and can nominally change at any time, I
> think we can just take out the assert.

I was thinking the same thing, then I thought about it more. All image decodes should be finished when the reftest finishes. and we haven't seen this failure for years, so why are we seeing it now?
Attachment #8949519 - Flags: review?(tnikkel) → review+
(In reply to Timothy Nikkel (:tnikkel) from comment #5)
> (In reply to Andrew Osmond [:aosmond] from comment #3)
> > (In reply to Timothy Nikkel (:tnikkel) from comment #2)
> > > Looks like the same reason as bug 1434935, so not introduced by what Andrew
> > > landed today.
> > 
> > Agreed. Given it is a live pref and can nominally change at any time, I
> > think we can just take out the assert.
> 
> I was thinking the same thing, then I thought about it more. All image
> decodes should be finished when the reftest finishes. and we haven't seen
> this failure for years, so why are we seeing it now?

Hmm, all image decodes that are part of the current view will be finished. The images could be coming from a previous test, and if the ordering of the tests recently changed, that could be enough.
Why would we be decoding a previous test though? Even if it is that seems like a bug, we don't need a decode of that. I suppose it could be an image in the ui like you mentioned in the commit message, that would make some sense.
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4afd35f217c1
Remove asserts checking that downscale-on-decode is enabled. r=tnikkel
Duplicate of this bug: 1427073
Duplicate of this bug: 1352665
Duplicate of this bug: 1434935
Duplicate of this bug: 1433726
https://hg.mozilla.org/mozilla-central/rev/4afd35f217c1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.