Crash in java.lang.OutOfMemoryError: at org.mozilla.gecko.gfx.DynamicToolbarAnimator.handleToolbarAnimatorMessage(DynamicToolbarAnimator.java)

RESOLVED FIXED in Firefox 59

Status

defect
--
critical
RESOLVED FIXED
2 years ago
8 months ago

People

(Reporter: philipp, Assigned: jchen)

Tracking

({crash, regression})

59 Branch
mozilla60
Unspecified
Android
Dependency tree / graph

Firefox Tracking Flags

(firefox58 unaffected, firefox59 fixed, firefox60 fixed)

Details

(crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is
report bp-3e4b2e2e-0594-487e-9a11-861dd0180201.
=============================================================
Java Stack Trace 	

java.lang.OutOfMemoryError
	at org.mozilla.gecko.gfx.DynamicToolbarAnimator.handleToolbarAnimatorMessage(DynamicToolbarAnimator.java:168)
	at org.mozilla.gecko.gfx.LayerSession.handleCompositorMessage(LayerSession.java:430)
	at org.mozilla.gecko.gfx.LayerSession$Compositor.recvToolbarAnimatorMessage(LayerSession.java:110)
	at org.mozilla.gecko.GeckoThread.runUiThreadCallback(Native Method)
	at org.mozilla.gecko.GeckoThread$1.run(GeckoThread.java:100)
	at android.os.Handler.handleCallback(Handler.java:733)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:136)
	at android.app.ActivityThread.main(ActivityThread.java:5001)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:797)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:613)
	at dalvik.system.NativeStart.main(Native Method)

=============================================================

this looks like a low volume regressing crash on fennec 59 from bug 1416319.
Given comment 0, I'll needinfo Jim.
Flags: needinfo?(nchen)
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
Comment on attachment 8949471 [details]
Bug 1435499 - Guard against OOM when getting toolbar pixels;

https://reviewboard.mozilla.org/r/218790/#review224582
Attachment #8949471 - Flags: review?(rbarker) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ad9f6cf50e5d
Guard against OOM when getting toolbar pixels; r=rbarker
https://hg.mozilla.org/mozilla-central/rev/ad9f6cf50e5d
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Comment on attachment 8949471 [details]
Bug 1435499 - Guard against OOM when getting toolbar pixels;

Approval Request Comment
[Feature/Bug causing the regression]: n/a
[User impact if declined]: rare crash when using Fennec
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple fix to avoid crash
[String changes made/needed]: none
Attachment #8949471 - Flags: approval-mozilla-beta?
Comment on attachment 8949471 [details]
Bug 1435499 - Guard against OOM when getting toolbar pixels;

Fix for a new crash from 59, let's take this for beta 10/11.
Attachment #8949471 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Product: Firefox for Android → GeckoView
Version: Firefox 59 → 59 Branch
Keywords: crash, regression
Target Milestone: Firefox 60 → mozilla60
You need to log in before you can comment on or make changes to this bug.