[Light theme] Window controls are rendered incorrectly when drawing tabs in titlebar

RESOLVED DUPLICATE of bug 1424422

Status

()

defect
RESOLVED DUPLICATE of bug 1424422
a year ago
a year ago

People

(Reporter: amit.prakash.ambasta, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug, {regression})

60 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 fix-optional, firefox60 affected)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

a year ago
Posted image Broken Titlebar.png (obsolete) —
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180204220351

Steps to reproduce:

Unpack nightly -> tar xvf firefox-60.0a1.en-US.linux-x86_64.tar.bz2
Run firefox -> ./firefox/firefox
Enabled drawing in titlebar. browser.tabs.drawInTitlebar = true


Actual results:

A smaller whitespacing remains where titlebar used to be (probably for drag controls) and the window controls are drawn b/w the tab bar and title bar.


Expected results:

The whitespacing above the tab bar should be removed or themed like the tab bar. Window controls should be made visible
(Reporter)

Comment 1

a year ago
Posted image gedit vs firefox (obsolete) —
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180207100355

Hello,

I have tested this issue on latest Nightly build 60.0a1 (2018-02-07) and managed to reproduce it. I have navigated to "about:config" page, changed the boolean pref "browser.tabs.drawInTitlebar" to "true" and a smaller whitespace was displayed above the tab bar. Indeed, I could use this white spacing for drag controls.

This white spacing was more visible on my testing machine with "Light Theme". For the "Dark Theme" it becomes black.

I have managed to find a regression window, using the Mozregression tool. Here are the results:
Last good revision: 5a46db143897c53211818c722f15c510dd708c6c
First bad revision: 7d2121c8e0dd75cc48d8021ba55565889da8aac7
Pushlog: https://goo.gl/xAeuXm

From the pushlog, it seems that bug 1417933 might have cause this issue. Martin, can you please take a look at this issue?
Blocks: 1417933
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Gtk
Ever confirmed: true
Flags: needinfo?(stransky)
Keywords: regression
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
What you see is a combination of Bug 1423851 and Bug 1419442. Let's close it as duplicate of Bug 1423851 as it's filed specifically for the Light theme.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(stransky)
Resolution: --- → DUPLICATE
Duplicate of bug: 1423851
(Reporter)

Comment 4

a year ago
Hi, the issue persists despite Bug 1423851 and Bug 1419442 being resolved in the latest nightly.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

a year ago
Posted image FF-Nightly-Titlebar-Issue.png (obsolete) —
Example of titlebar and window controls on latest nightly
Attachment #8948342 - Attachment is obsolete: true
(Reporter)

Comment 6

a year ago
Posted image Comparison of chrome vs firefox (obsolete) —
Highlighting the issue with window controls vs chrome browser
Martin, can you please take another look?
Flags: needinfo?(stransky)
That's a bug at built-in Light theme only. We can surely leave it open until it's fixed.
Flags: needinfo?(stransky)
Summary: Window controls are rendered incorrectly when drawing tabs in titlebar → [Light theme] Window controls are rendered incorrectly when drawing tabs in titlebar
Blocks: gtktitlebar
No longer blocks: 1417933
It also depends on Bug 1424422 which fixes titlebar button rendering on lwt themes.
Depends on: 1424422
Seems to be fixed for me with latest nightly. Can you retest please?
Flags: needinfo?(amit.prakash.ambasta)
(Reporter)

Comment 11

a year ago
Hi,

I can confirm that the latest nightly does indeed resolve the issue!
Attachment #8948343 - Attachment is obsolete: true
Attachment #8952630 - Attachment is obsolete: true
Attachment #8952631 - Attachment is obsolete: true
Flags: needinfo?(amit.prakash.ambasta)
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1424422
You need to log in before you can comment on or make changes to this bug.