Closed Bug 1435990 Opened 5 years ago Closed 5 years ago

Adressbar sometimes wont react to an enter

Categories

(Firefox :: Address Bar, defect)

58 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: unclesam, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180130211649

Steps to reproduce:

0. Install Firefox on Fedora 26/27 using an fresh installation without any addons
1. Enter a single word/webdomain into the adressbar
2. press enter


Actual results:

Most of the times, it seem to work, then sometimes it works when u open an second tab and try to open it their, sometimes even that wont work. 

What seems to work all the time is when u enter several words/symbols divided by an space, also using the little arrow button opens up the search word or the domain.




Expected results:

Accepted the return button and open up the search word or the domain u try to open.
Component: Untriaged → Address Bar
Which antivirus do you have?
Could you please try to enable "Prevent Accessibility tools from accessing the browser" option?
Flags: needinfo?(unclesam)
See Also: → 1427166, 1427224
Did you check the error console to see if there was anything?
(In reply to Mike Kaply [:mkaply] from comment #3)
> Did you check the error console to see if there was anything?
Nope, every time to press the button i dont see any new line in the console

(In reply to Marco Bonardo [::mak] from comment #1)
> Which antivirus do you have?
> Could you please try to enable "Prevent Accessibility tools from accessing
> the browser" option?

I enabled the option - still no changes

(In reply to Drew Willcoxon :adw from comment #2)
> This sounds like bug 1427166 or bug 1427224.

i saw this bug too, but it seems to be a different problem, as he wont take any searches or entering a full domain name (neither with www.xyz.com or just an ending like .com / even setting an http:// in front doesnt seem to work... )
Flags: needinfo?(unclesam)
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build-ID: 20180206200532
Fedora 26


I think I encounter the same bug.

Steps to reproduce:

0. Install Firefox on Fedora 26/27 using an fresh installation without any addons
1. Press ctrl-t to open new tab
2. Start writing stuff (no suggestions appears)
3. Press Enter

Actual results:

Most of times, it seems to work, but sometimes not. I need to close and re-open a new tab, or use "+" sign to have a responsive address bar.

Expected results:

I expect to have suggestions and to go to location when pressing Enter.
Please check the suggestion in comment 1, in case it helps.
Bug 1438329 should have fixed the last known instance of this in Firefox 60, so I'm marking it as WFM. If when FF 60 is released   you still find this problem, please file a new bug.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Depends on: 1438329
Resolution: --- → WORKSFORME
Thank you Marco!
Sorry for inconvenience.
You need to log in before you can comment on or make changes to this bug.