Audit unit test coverage for Sanitizer.jsm

RESOLVED DUPLICATE of bug 1538633

Status

()

enhancement
P2
normal
RESOLVED DUPLICATE of bug 1538633
a year ago
2 months ago

People

(Reporter: johannh, Unassigned)

Tracking

60 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox60 affected)

Details

(Whiteboard: [storage-v2])

Reporter

Description

a year ago
Sanitizer.jsm is intended to become our internal one-stop-shop for clearing data. Its (unit) test coverage should be rock solid and extra thorough.

The existing tests that test the module directly were all touched in this commit and should be easy to find that way:

https://hg.mozilla.org/mozilla-central/rev/092f32e30ed9

That list doesn't inspire a lot of confidence to me, but I might be wrong about it.

We currently have most tests in browser/base/content/test/sanitize, though they function very much like unit tests. It would be cool to be able to use xpcshell tests for this as well.
Reporter

Updated

a year ago
Whiteboard: [storage-v2] → [storage-v2][triage]
Reporter

Updated

a year ago
Priority: P3 → P2
Whiteboard: [storage-v2][triage] → [storage-v2]
Reporter

Comment 1

2 months ago

Duping forward to bug 1538633

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1538633
You need to log in before you can comment on or make changes to this bug.