Closed Bug 1436040 Opened 3 years ago Closed 3 years ago

xslt processor: <?xslt-param name= value= ?> isn't recognized

Categories

(Core :: XSLT, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- wontfix
firefox59 --- wontfix
firefox60 --- fixed
firefox61 --- fixed

People

(Reporter: henrik.haftmann, Assigned: peterv)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180128191252

Steps to reproduce:

I did nothing, the problem arised with a firefox automatic update.

I use xslt processing instruction <?xslt-param name="svgpre" value="svg:"?> to distinct SVG namespace output for Firefox and no SVG namespace output for other browsers.

Test file:
http://www.tu-chemnitz.de/~heha/enas/MiniIO/Eagle.zip/MiniIO.sch?as=SVG


Actual results:

Nothing to see (as SVG namespace is missing due to non-functional `xslt-param´ access)


Expected results:

A small schematic as interactive SVG file
Assignee: nobody → peterv
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2
Attached patch v1 (obsolete) — Splinter Review
Attached patch v1Splinter Review
Attachment #8954676 - Attachment is obsolete: true
Attachment #8956752 - Flags: review?(bzbarsky)
Comment on attachment 8956752 [details] [diff] [review]
v1

r=me
Attachment #8956752 - Flags: review?(bzbarsky) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/21edf57115997ad529c68f0ac8bfb45e151f8329
Bug 1436040 - xslt processor: <?xslt-param name= value= ?> isn't recognized. r=bz.
https://hg.mozilla.org/mozilla-central/rev/21edf5711599
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Comment on attachment 8956752 [details] [diff] [review]
v1

Approval Request Comment
[Feature/Bug causing the regression]: bug 1387427
[User impact if declined]: some web pages stop working
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: bug 1430818
[Is the change risky?]: fairly low-risk
[Why is the change risky/not risky?]: makes this code work like it used to before bug 1387427 landed. Also, limited to XSLT, which is not widely used.
[String changes made/needed]: none
Attachment #8956752 - Flags: approval-mozilla-beta?
Comment on attachment 8956752 [details] [diff] [review]
v1

xslt regression fix, approved for 60.0b14
Attachment #8956752 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.