Cloud ad is very slow in WebRender

RESOLVED FIXED

Status

()

enhancement
P2
normal
RESOLVED FIXED
2 years ago
6 months ago

People

(Reporter: jrmuizel, Assigned: gw)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

https://jrmuizel.github.io/webrender/slow/coulds.html

It looks like we're spending a bunch of time blurring.
You can assign this one to me, if you like. I imagine we'll want to add image blurs to the list of items we pre-render to the texture cache, or something similar.
Assignee: nobody → gwatson
I profiled this briefly - in this case it's actually text shadows being used for the effect. We'll want to cache text-shadow blurs, just as we do for box-shadows.
Could bug 1452489 be a (long winded) duplicate of this?
We can't release this to the field, but we can let this ride to beta.
Priority: P1 → P2
Depends on: picture-caching
The initial patch for picture caching on text shadows is https://github.com/servo/webrender/pull/3270. The commit mentions:

This brings the GPU time in the cloud ad [1] from 43 ms down to
8 ms for me. This is still higher than we want, due to the very high
number of cached text shadows that get composited. This should be
resolved as we support nested picture caching.

I think it's probably OK to verify and mark this as fixed once that lands, as it makes the performance very usable. It's just not as fast as we want / expect it to be in the future.
Depends on: 1505778

This works really well now, with picture caching enabled by default.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.