Closed Bug 143621 Opened 18 years ago Closed 18 years ago

Install corrupted MIME types, file associations

Categories

(SeaMonkey :: General, defect, major)

x86
Windows 98
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 131106

People

(Reporter: hippie, Assigned: Matti)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051006

I uninstalled 1.0rc1.  I then installed 1.0rc2.  I selected 'custom install',
but then decided to leave all the components selected.

I don't recall seeing any prompts for it, but Mozilla seems to have reset my
file associations for GIF, JPG, PNG, and others against my will.  I don't recall
rc1 or the previous 0.99 build doing this.

It also seems to have wiped out my MIME settings; now when clicking on an mpg,
it opens quicktime right in the window, instead of either a) opening a "Save
As..." dialog like I'd set it to before, or b) asking if I wanted to save or
open--it just opened by default.

Under Preferences->Helper Applications, the [Reset] button seems to do nothing,
and there are no file types listed in the display.

Reproducible: Didn't try
Steps to Reproduce:
Not much I can do to reproduce it, as I can't seem to fix things back to how
they were.

Expected Results:  Mozilla should at the VERY LEAST prompt me if I want to
override my current windows file associations in regards to images.

It most definitely shouldn't have reset my MIME types, and if it does, it should
offer an option to set them BACK somehow.

I'm sorry if I'm not clear on this; I realize it's a release CANDIDATE and not a
release, but I failed to make a backup of my preferences (and registry?) before
installing rc2 and it's bitten me on the heiney.
> now when clicking on an mpg, it opens quicktime right in the window

This is because we now correctly find plugins that are installed on the machine.
 It's being started as a plugin, not a helper, hence no prompt (plugins never
prompt to start).

The other issue is still valid -- we should not be resetting file associations
without prompting...  (I believe that is reported already, however).
Whiteboard: DUPEME
> The other issue is still valid -- we should not be
> resetting file associations without prompting...

This seems to be done when the user gets the initial "Do you want to use Mozilla
as your default browser?" prompt.  I answered No, went into preferences and told
it not to become the viewer for gif,jpg,png, and then restarted Mozilla (this
time saying, "Yes, I want it to be my default /BROWSER/" and it didn't shanghai
my file associations.

I guess it's just not clear that making it a default browser will take not only
.htm and .html but images as well.
Not sure what the solution wanted is, but it's not the installer doing this so
over to law. For the most part we *do* want to grab the filetypes we know we can
handle, and we *don't* want to present a cluttered collection of checkboxes for
different types when we ask if the user wants to make us the default browser.

Unchecking filetypes in the preference dialog will revert to the previous app.
Do we simply need to make that easier to find?
Assignee: dveditz → law
Status: UNCONFIRMED → NEW
Component: Installer → Browser-General
Ever confirmed: true
> Unchecking filetypes in the preference dialog will revert to the previous app.

I could've /sworn/ I tried this on my home machine, and it didn't work... but it
works fine on my work machine.  D'oh.

> Do we simply need to make that easier to find?

It was findable, but it wasn't clear (to me) that unchecking the file types
would restore their previous associations or just "forget" all about them.  But
then, I'm kind of a goober.

I'll just get used to right-click/save link target on movies.
not me
Assignee: law → Matti
QA Contact: bugzilla → imajes-qa
also not me


*** This bug has been marked as a duplicate of 131106 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.