Closed Bug 1436331 Opened 3 years ago Closed 3 years ago

Text rendering sometimes gets slightly moved on the left

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1396637
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected

People

(Reporter: gerard-majax, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(3 files)

Attached image Twitter-GNOME.png
I've noticed that everytime I do have pending notifications on Twitter, but I've also spotted that on other text in web content.
Now, taking the screenshot with Firefox' tooling does provide a slightly different rendering.
Attached file about:support
Yeah, don't use the screenshot extension for gfx-related stuff, it doesn't use the same rendering engine (it creates a temporary basic layer manager in the content process and renders it using skia).
"See also" or "Duplicate of" bug 1435387? I am unsure.

(In reply to Alexandre LISSY :gerard-majax from comment #0)
Do you also have seen glyphs that are cut-off on the left? (Example: https://geizhals.at/ = attachment 8947971 [details])
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Version: unspecified → Trunk
Yes, what you show is actually the other case I spotted that I mentionned in comment 0. Obviously, we see the same thing, but whether the present bug is a dupe from 1435387, I'm unsure as well, we might be having different issues there.
Flags: needinfo?(jan)
Flags: needinfo?(jan)
See Also: → 1435387
Assignee: nobody → a.beingessner
Priority: -- → P1
This may be fixed by bug 1396637. We should reevaluate once that lands.
Depends on: 1396637
(In reply to Alexandre LISSY :gerard-majax from comment #0)
Is it fixed now?
Flags: needinfo?(lissyx+mozillians)
Yes, as much as I can tell, with the update pulling bug 1396637 it looks to be fixed! Thanks!
Flags: needinfo?(lissyx+mozillians)
Assignee: a.beingessner → nobody
Status: NEW → RESOLVED
Closed: 3 years ago
No longer depends on: 1396637
Resolution: --- → DUPLICATE
Duplicate of bug: 1396637
You need to log in before you can comment on or make changes to this bug.