Closed Bug 1436416 Opened 2 years ago Closed 2 years ago

[wpt-sync] PR 9422 - [css-typed-om] update CSSUnparsedValue.idl

Categories

(Core :: DOM: CSS Object Model, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: wptsync, Assigned: jgraham)

Details

(Whiteboard: [wptsync upstream error])

1. replace "DOMString or CSSVariableReferenceValue" with
 CSSUnparsedSegment using typedf keyword.
2. using sequence<> keyword instead of "..." in constructor

https://github.com/w3c/css-houdini-drafts/pull/619

Bug: 807525
Change-Id: I99c11c26dd2235e46e259e63991d0192a025bcb4

Reviewed-on: https://chromium-review.googlesource.com/904582
WPT-Export-Revision: 0114692f85a4a69616b5a4bc88e54fae6092db30
Component: web-platform-tests → DOM: CSS Object Model
Product: Testing → Core
Whiteboard: [wptsync downstream] → [wptsync downstream error]
[ Triage 2017/02/20: P3 ]
Priority: -- → P3
Whiteboard: [wptsync downstream error] → [wptsync downstream]
Ran 18 tests and 67 subtests
OK     : 18
PASS   : 2
FAIL   : 65
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b7d1504387a
[wpt PR 9422] - [css-typed-om] update CSSUnparsedValue.idl, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ce98b09f438
[wpt PR 9422]- Update wpt metadata, a=testonly
Whiteboard: [wptsync downstream] → [wptsync upstream error]
https://hg.mozilla.org/mozilla-central/rev/7b7d1504387a
https://hg.mozilla.org/mozilla-central/rev/1ce98b09f438
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
After backing out https://bugzilla.mozilla.org/show_bug.cgi?id=1443558#c4 the wpt tests started mass failing as you can see on this push https://goo.gl/Awm6eR  

I decided to backout all the changesets from the original push https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=5138dcf1eddd750c06e05a784f170b771ba58f60 because of this mass wpt failures.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(bugs)
Resolution: FIXED → ---
Target Milestone: mozilla60 → ---
The changes landed in this bug back out various changes made in bug 1364025 (idlharness.js, payment-request/interfaces.https.html).  That led to some of the test failures.  Merge fail of some sort?  I don't see those backouts in https://github.com/w3c/web-platform-tests/pull/9422/files ...
Flags: needinfo?(james)
So the way landings work is that we copy upstream and then reapply local changes that haven't landed yet. This limits how badly things can go wrong in the long term since we can only diverge from upstream by a known amount (compared to the strategy where we copy across patches from upstream). But it does have the failure case where we fail to reapply something from mozilla-central so a change gets lost until we sync to an upstream point where it has landed. I think is what went wrong here. It isn't helped by the fact that we're somewhat behind upstream at the moment as we fix some bugs, so there are  a lot of things to reapply.

Anyway I've redone the branch manually and I think it's right now, so when this relands I
Flags: needinfo?(james)
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6296417d90a9
[wpt PR 9422] - [css-typed-om] update CSSUnparsedValue.idl, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/3b92a34323d9
[wpt PR 9422]- Update wpt metadata, a=testonly
https://hg.mozilla.org/mozilla-central/rev/6296417d90a9
https://hg.mozilla.org/mozilla-central/rev/3b92a34323d9
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Assignee: nobody → james
Flags: needinfo?(bugs)
You need to log in before you can comment on or make changes to this bug.