Closed Bug 1436477 Opened 3 years ago Closed 3 years ago

Firefox DevTools Network Tab doesn't support copying response body exceeding 1 MB

Categories

(DevTools :: Netmonitor, defect)

59 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1223726

People

(Reporter: amjad.4, Unassigned)

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:59.0) Gecko/20100101 Firefox/59.0
Build ID: 20180122144853

Steps to reproduce:

I opened Network Tab of DevTools and was checking the response of an API in a web page for work. 


Actual results:

The actual response size was ~2.80 MB but when I try checking the response or copying it through right-click context menu, it seems that Firefox clips it at 1048576 bytes (1024 * 1024 bytes or 1 MiB). Is this a known issue?


Expected results:

The entire response should have appeared in the response tab, and also copying the response using the right-click context menu should copy the entire response.
Attachment #8949123 - Attachment is obsolete: true
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Component: Untriaged → Developer Tools: Netmonitor
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1223726
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.