3.83 - 4% sessionrestore / sessionrestore_no_auto_restore / ts_paint / ts_paint_webext (windows10-64) regression on push f37162b6183944f2e38ab82651377cd83b038288 (Wed Feb 7 2018)

RESOLVED FIXED in Firefox 60

Status

()

defect
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: igoldan, Assigned: aklotz)

Tracking

(Blocks 1 bug, {perf, regression, talos-regression})

unspecified
mozilla60
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 fixed)

Details

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=f37162b6183944f2e38ab82651377cd83b038288

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  4%  sessionrestore_no_auto_restore windows10-64 pgo e10s     441.04 -> 458.67
  4%  ts_paint_webext windows10-64 pgo e10s                    546.67 -> 567.83
  4%  sessionrestore windows10-64 pgo e10s                     376.17 -> 390.58
  4%  ts_paint windows10-64 pgo e10s                           486.54 -> 505.17


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=11437

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → Crash Reporting
Product: Firefox → Toolkit
:aklotz It looks like these regressions relate to bug 1430857, because the push-backout-push again pattern shows up on the performance graphs.
I did some retriggers and will properly confirm this. Can you please take a look over the bug in question. Is there something we can do to fix it or should we accept it/back it out?
Flags: needinfo?(aklotz)
(Assignee)

Comment 2

a year ago
I don't want to do a full backout, but I will land a change to temporarily disable the problematic code.
Flags: needinfo?(aklotz)

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5472cdf7d744
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
(Assignee)

Updated

a year ago
Depends on: 1437309
You need to log in before you can comment on or make changes to this bug.