Closed Bug 1436747 Opened 2 years ago Closed 2 years ago

Crash in vrclient.dylib@0x17f087

Categories

(Core :: WebVR, defect, critical)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1436944
Tracking Status
firefox60 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-0ee5ab4b-a5e1-40ba-a665-51bed0180206.
=============================================================

Spotted a handful of these crashes while going through nightly crash stats, all appear to be present on 10.13: http://bit.ly/2BiaQM2

Since WebVR is in the 60 timeframe I thought it prudent to file it.

URLs:
*https://apainter.webxrexperiments.com/?url=https://ucarecdn.com/962b242b-87a9-422c-b730-febdc470f203/
*https://s3-us-west-1.amazonaws.com/nubaassets.emblematicvr.com/Sundance/Sundance-experiment-demo/SarahWolozin.html

Top 10 frames of crashing thread:

0 vrclient.dylib vrclient.dylib@0x17f087 
1 vrclient.dylib vrclient.dylib@0x180026 
2 vrclient.dylib vrclient.dylib@0x14e2d 
3 vrclient.dylib vrclient.dylib@0x71141 
4 vrclient.dylib vrclient.dylib@0x709be 
5 XUL vr::VR_InitInternal gfx/vr/openvr/src/openvr_api_public.cpp:51
6 XUL mozilla::gfx::VRSystemManagerOpenVR::Enumerate gfx/vr/openvr/headers/openvr.h:3706
7 XUL mozilla::gfx::VRManager::EnumerateVRDisplays gfx/vr/VRManager.cpp:300
8 XUL mozilla::gfx::VRManager::RefreshVRDisplays gfx/vr/VRManager.cpp:323
9 XUL mozilla::gfx::VRManager::NotifyVsync gfx/vr/VRManager.cpp:216

=============================================================
Duping this to Bug 1436944 since it appears to be the Mac version of the crash.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1436944
You need to log in before you can comment on or make changes to this bug.