Closed Bug 1436765 Opened 4 years ago Closed 4 years ago

New Browser console window doesn't have a border

Categories

(DevTools :: Console, defect, P1)

defect

Tracking

(firefox60 fixed)

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: Honza, Assigned: bgrins)

References

Details

(Whiteboard: [newconsole-mvp])

Attachments

(2 files)

Attached image new-browser-console.png
The new Browser console window doesn't have a border when the new front-end is enabled for it. This means that eg the window can't be resized or moved.

I am using the following pref:
devtools.browserconsole.new-frontend-enabled

It happens on Win10

Screenshot attached.

Honza
Whiteboard: [reserve-console-html]
Looks like a win only issue, it's working fine on OSX
I'm guessing this is because we aren't loading global.css in browserconsole.xul.
Blocks: 1362023
Priority: -- → P3
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [reserve-console-html] → [newconsole-mvp]
Comment on attachment 8950673 [details]
Bug 1436765 - Include global.css in browserconsole.xul to restore window border;

https://reviewboard.mozilla.org/r/219930/#review225940

Border's back, thanks,
R+
Honza
Attachment #8950673 - Flags: review?(odvarko) → review+
Pushed by bgrinstead@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26101dcb2ece
Include global.css in browserconsole.xul to restore window border;r=Honza
https://hg.mozilla.org/mozilla-central/rev/26101dcb2ece
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
I am unable to reproduce this issue on either Firefox 60.0b16 (20180426170554) on Windows 10x64 or on Firefox Nightly 61.0a1 (20180504220115) on Windows 10x64.

[bugday-20180502]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.