Active browser window disappears

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: j.buccino, Assigned: doronr)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    rc2

When I do not allow webpages to open new windows (Advanced - Scripts and
Windows) which the above URL tries to do, the active browser window disappears
when loading the above URL.

Reproducible: Always
Steps to Reproduce:
1. Set preferences to not allow webpages to open new windows
2. Access URL
3.

Actual Results:  Active browser window disappears, have to open new one to continue

Expected Results:  Browser window shoes typical content, supplementary window
does not appear.

Comment 1

17 years ago
The website has javascript (in http://www.celestron.com/code/general.js) which
looks like this:

MyWin = window.open(url,wname,[snip details]);
if (MyWin == null) window.close();  

So, if it can't open a popup, it shuts the window.  Lovely.  Either:
a) it's a crude way of making you accept the popup, or 
b) they goofed.

If it's (a), then we're unlikely to make them fix it, but if it's (b), we stand
a chance.

->Tech evangelism

Contact details: http://www.celestron.com/contact.htm or webmaster@celestron.com
Assignee: sgehani → doron
Status: UNCONFIRMED → NEW
Component: XP Apps → US General
Ever confirmed: true
OS: MacOS X → All
Product: Browser → Tech Evangelism
QA Contact: paw → zach
Hardware: Macintosh → All
Version: other → unspecified

Comment 2

17 years ago
Reporter has contacted them, their response as follows:

-------------start

Dear Mr. Buccino: 

I am very sorry for the inconvenience. I am glad that you brought this to our 
attention. We will modify the script to remove the part of the code that kills 
the window if null. In addition, we will be moving away from using popup windows 
in the future. I agree with you that they are annoying!

-------------end

To cap it all, they've ALREADY changed the page.  Looks like option (b) was the
case, and Ten out of Ten for quick turnaround on their part...
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.