Update Fluent in Gecko to 0.6.2

RESOLVED FIXED in Firefox 59

Status

()

defect
P3
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: zbraniecki, Assigned: zbraniecki)

Tracking

unspecified
mozilla60
Points:
---

Firefox Tracking Flags

(firefox58 wontfix, firefox59+ fixed, firefox60+ fixed)

Details

Attachments

(1 attachment)

Comment hidden (mozreview-request)
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Priority: -- → P3

Comment 2

Last year
mozreview-review
Comment on attachment 8949485 [details]
Bug 1436790 - Update Fluent in Gecko to 0.6.2.

https://reviewboard.mozilla.org/r/218802/#review224600
Attachment #8949485 - Flags: review?(l10n) → review+

Comment 3

Last year
Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0cd30c515243
Update Fluent in Gecko to 0.6.2. r=Pike
We'll want to request beta uplift for the following three bugs: bug 1426054, bug 1432229 and bug 1436790.

Reason: all three bugs are required to bring the updated version of new localization API (Fluent) to 0.6. Since we're using cross-channel for localization we'd like to start serializing our l10n to use 0.6 syntax in the localization tool (Pontoon).
Once we do, we'll need the updated parser in 59 to be able to read the output.

I'll request uplift for each patch separately, but placing them on the release mgmt radar together.
That sounds fine. As long as it isn't late in the release cycle so we have the chance to work out any problems.

Comment 6

Last year
bugherder
https://hg.mozilla.org/mozilla-central/rev/0cd30c515243
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Comment on attachment 8949485 [details]
Bug 1436790 - Update Fluent in Gecko to 0.6.2.

Approval Request Comment
[Feature/Bug causing the regression]: none
[User impact if declined]: none, but complications in our build system which may indirectly lead to us not having a good way to uplift strings to 59.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: bug 1426054 and bug 1432229
[Is the change risky?]: no
[Why is the change risky/not risky?]: this is at most affecting 5 strings in preferences and they all work in Nightly for a while now.
[String changes made/needed]: none
Attachment #8949485 - Flags: approval-mozilla-beta?
Comment on attachment 8949485 [details]
Bug 1436790 - Update Fluent in Gecko to 0.6.2.

Great. Should land for Thursday's beta 10 build.
Attachment #8949485 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.