Closed Bug 1436991 Opened 2 years ago Closed 2 years ago

[wpt-sync] PR 9433 - custom-elements: document.createElementNS should not create HTMLUnknownElement for a valid custom element name

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: wptsync, Assigned: jgraham)

Details

(Whiteboard: [wptsync upstream error])

Document::CreatRawElement() should check CustomElement::IsValidName().
It failed only if the Document didn't have V0 RegistrationContext.

Bug: 809887
Change-Id: I4e5d283658673db3e1db15b136ca5729d29e2442

Reviewed-on: https://chromium-review.googlesource.com/908128
WPT-Export-Revision: a7887246b8c4f3b3f9b2ea6a6d0f4cadb1152359
Component: web-platform-tests → DOM
Product: Testing → Core
Ran 1 tests and 5 subtests
OK     : 1
PASS   : 4
FAIL   : 1
Priority: -- → P3
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9673a31cbd06
[wpt PR 9433] - custom-elements: document.createElementNS should not create HTMLUnknownElement for a valid custom element name, a=testonly
Whiteboard: [wptsync downstream] → [wptsync upstream error]
https://hg.mozilla.org/mozilla-central/rev/9673a31cbd06
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
After backing out https://bugzilla.mozilla.org/show_bug.cgi?id=1443558#c4 the wpt tests started mass failing as you can see on this push https://goo.gl/Awm6eR  

I decided to backout all the changesets from the original push https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=5138dcf1eddd750c06e05a784f170b771ba58f60 because of this mass wpt failures.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(overholt)
Resolution: FIXED → ---
Target Milestone: mozilla60 → ---
We're not finished with our Custom Elements implementation yet so I'm not surprised there are problems. Olli or Blake will know what to do.
Flags: needinfo?(overholt)
Flags: needinfo?(mrbkap)
Flags: needinfo?(bugs)
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ea4f0746ad6
[wpt PR 9433] - custom-elements: document.createElementNS should not create HTMLUnknownElement for a valid custom element name, a=testonly
https://hg.mozilla.org/mozilla-central/rev/3ea4f0746ad6
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Assignee: nobody → james
Flags: needinfo?(mrbkap)
Flags: needinfo?(bugs)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.