[wpt-sync] PR 9435 - IndexedDB WPT: Break down interleaved-cursors test.

RESOLVED FIXED in Firefox 60

Status

()

enhancement
P2
normal
RESOLVED FIXED
2 years ago
11 months ago

People

(Reporter: wptsync, Assigned: janv)

Tracking

unspecified
mozilla60
Points:
---

Firefox Tracking Flags

(firefox60 fixed)

Details

(Whiteboard: [wptsync upstream error])

The test is currently flaky on the CQ (see associated bug) due to timing
out. This CL breaks down the test in a -small and a -large file. The
size of the largest test is also reduced from 500 cursors to 250
cursors. The two changes combined should greatly reduce the chance of
timeouts.

Bug: 708175
Change-Id: Ic58c59740a0176e6bc5e6e87b66c5d772a67526a
Reviewed-on: https://chromium-review.googlesource.com/908248
WPT-Export-Revision: 813c914449ddbfb0b5ce938b8c9ce7f2e4a24f48
Component: web-platform-tests → DOM: IndexedDB
Product: Testing → Core
Priority: -- → P2
Ran 2 tests and 4 subtests
OK     : 2
PASS   : 4
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fd8dcd647f0e
[wpt PR 9435] - IndexedDB WPT: Break down interleaved-cursors test., a=testonly
Whiteboard: [wptsync downstream] → [wptsync upstream error]
https://hg.mozilla.org/mozilla-central/rev/fd8dcd647f0e
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
After backing out https://bugzilla.mozilla.org/show_bug.cgi?id=1443558#c4 the wpt tests started mass failing as you can see on this push https://goo.gl/Awm6eR  

I decided to backout all the changesets from the original push https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=5138dcf1eddd750c06e05a784f170b771ba58f60 because of this mass wpt failures.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(mdaly)
Resolution: FIXED → ---
Target Milestone: mozilla60 → ---
Assignee: nobody → jvarga
Flags: needinfo?(mdaly)
:janv please take a look
Flags: needinfo?(jvarga)
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2a80b7b02e4
[wpt PR 9435] - IndexedDB WPT: Break down interleaved-cursors test., a=testonly
https://hg.mozilla.org/mozilla-central/rev/d2a80b7b02e4
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Flags: needinfo?(jvarga)
You need to log in before you can comment on or make changes to this bug.