Closed Bug 1437005 Opened 4 years ago Closed 4 years ago

[wpt-sync] PR 9349 - [Code Health] Fix ABC wpt.browser.Browser

Categories

(Testing :: web-platform-tests, enhancement)

enhancement
Not set
normal

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: mozilla.org, Unassigned)

Details

(Whiteboard: [wptsync downstream])

* Make sure methods in subclasses have the same interface as the
  abstract methods in the base class.
* Move docstrings to the base class.
* Declare two more abstract methods: find_binary & find_webdriver,
  because multiple (though not all) subclasses already defined these
  methods, and the two methods are called externally (by wpt.run). They
  fall into the same category as version().
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/91e1520d3304
[wpt PR 9349] - [Code Health] Fix ABC wpt.browser.Browser, a=testonly
https://hg.mozilla.org/mozilla-central/rev/91e1520d3304
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.