Closed Bug 1437021 Opened 3 years ago Closed 3 years ago

[Ubuntu] Space inconsistency between characters inside Simplify Page

Categories

(Toolkit :: Printing, defect, P3)

60 Branch
All
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- disabled
firefox60 --- fixed

People

(Reporter: ciprian_georgiu, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Space inconsistency.png
[Affected versions]:
- 60.0a1 (2018-02-08)

[Affected platforms]:
- Ubuntu 16.04 x32
- Ubuntu 16.04 x64
- Ubuntu 14.04 x64

[Steps to reproduce]:
1. Open Firefox.
2. Go to https://goo.gl/Z8sCcF
3. Open the Print preview page from menu bar
4. Click on the Simplify page button
5. Observe the characters (especially around “g” and “t” characters)

[Expected result]:
- Characters are displayed uniform, there is no space inconsistency between them.

[Actual result]:
- There are noticeable space gaps and overlapped characters inside random words, more visible around “g” and “t” characters.

[Regression range]:
- This seems to be regression as I cannot reproduce it on FF 57.0 (12.11.2017). I will follow-up with a regression range asap.

[Additional notes]:
- Note that this issue is more noticeable on x32 platforms, and also its severity depends on the chosen article, in some cases it is barely perceivable.
- We encounter the same behaviour regardless if the page is displayed in Portrait or Landscape mode.
- In Reader view mode, the characters are properly displayed.
- Windows 10 x64 is not affected by this problem.
- Other websites affected: wikipedia.org, bbc.com.
FYI,
In Beta59, the Simplify page button is disabled by pref "print.use_simplify_page".
If forcibly enabled the preference, then I can also reproduce the text rendering issue on Beta59.0b8.
Duplicate of bug 1435234?
(In reply to Gian-Carlo Pascutto [:gcp] from comment #3)
> Duplicate of bug 1435234?

If so, then I believe this should be fixed now. Hey Alice0775 White, can you confirm that this issue is fixed?
Flags: needinfo?(alice0775)
Priority: -- → P3
Yes, Recent 60.0b12 and Nightly61.0a1 are much better than the before(the bad build of comment#1). It seems to have been fixed.
Flags: needinfo?(alice0775) → needinfo?(ciprian.georgiu)
I can confirm on my side too, that on the latest Beta (60.0b13) and latest Nighly (60.0a1 - 2018-04-17), the issue looks way better now, the still existing inconsistencies are barely noticeable.
Flags: needinfo?(ciprian.georgiu)
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1435234
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
(In reply to Ciprian Georgiu, QA [:ciprian_georgiu] from comment #0)
> [Steps to reproduce]:
> 1. Open Firefox.
> 2. Go to https://goo.gl/Z8sCcF

For the record -- it looks like the actual page involved here (not goo.gl which is simply a redirector) is:
https://banyanhill.com/exclusives/bitcoin-millionaires-shocked-by-new-stock/

--> setting that in URL field
You need to log in before you can comment on or make changes to this bug.