Closed Bug 1437045 Opened 2 years ago Closed 2 years ago

[wpt-sync] PR 9442 - [LayoutNG] Improve min/max calculation wrt. floats.

Categories

(Core :: CSS Parsing and Computation, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: wptsync, Unassigned)

Details

(Whiteboard: [wptsync downstream])

The presence of floats complicate min/max intrinsic inline size
calculation. They affect lines and child blocks in the same block
formatting context. Therefore, when calculating min/max sizes of a
child, we need to pass along information about floats adjacent to the
current "virtual" block position.

This change actually makes NG slightly "better" than legacy Blink
layout, Edge and Firefox. This may be an issue for compatibility. It
should be fairly easy to "dumb down" the machinery to be compatible with
the others, though, if this should become an issue. Two tests regressed
because of this. Reported bug 810370. This change also caused
grid-item-margins-not-collapse-expected.html to make room for the floats to
fit beside each other, so I modified it. Also removed bogus "margin"
attributes.

Cq-Include-Trybots: master.tryserver.chromium.linux:linux_layout_tests_layout_ng
Change-Id: I59730d7333fa7699a42ab93d2c4674c267d834aa

Reviewed-on: https://chromium-review.googlesource.com/908753
WPT-Export-Revision: 5845787afb710b5553139203aa889bd4e1ae5a99
Component: web-platform-tests → CSS Parsing and Computation
Product: Testing → Core
Ran 1 tests
PASS   : 1
[ Triage 2017/02/20: P3 ]
Priority: -- → P3
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8263aedb061d
[wpt PR 9442] - [LayoutNG] Improve min/max calculation wrt. floats., a=testonly
https://hg.mozilla.org/mozilla-central/rev/8263aedb061d
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.