Closed Bug 1437067 Opened 2 years ago Closed 2 years ago

[wpt-sync] PR 9400 - [css-align] justfy-items accepts 'legacy' and drops support for 'auto'

Categories

(Core :: CSS Parsing and Computation, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: wptsync, Assigned: jgraham)

Details

(Whiteboard: [wptsync upstream error])

The syntax of the 'justify-items' property accepts a new 'legacy' value,
replacing the 'auto' value which is now parsed as invalid.

https://github.com/w3c/csswg-drafts/issues/1318

This change affects also to the 'place-items' shorthand, which doesn't
accept 'auto' and, for the time being, neither 'legacy'.

Link to the intent-to-ship-and-remove request:

https://groups.google.com/a/chromium.org/d/msgid/blink-dev/552753c1-9b2f-bb01-4fed-2ae621f2398e%40igalia.com?utm_medium=email&utm_source=footer

Bug: 726147, 726148
Change-Id: I219de66b813d350fe33f00a1d4369bed8e9a2350
Reviewed-on: https://chromium-review.googlesource.com/903162
Commit-Queue: Javier Fernandez <jfernandez@igalia.com>
Reviewed-by: Christian Biesinger <cbiesinger@chromium.org>
Reviewed-by: Darren Shen <shend@chromium.org>
Cr-Commit-Position: refs/heads/master@{#535593}
Component: web-platform-tests → CSS Parsing and Computation
Product: Testing → Core
Ran 3 tests and 22 subtests
OK     : 3
PASS   : 17[linux64-stylo-disabled-debug,linux64-stylo-disabled-opt], 20[linux32-debug,linux32-opt,linux64-debug,linux64-opt]
FAIL   : 2[linux32-debug,linux32-opt,linux64-debug,linux64-opt], 5[linux64-stylo-disabled-debug,linux64-stylo-disabled-opt]

These new tests don't PASS on all platforms
/css/css-align/default-alignment/place-items-shorthand-004.html
    Verify 'auto' value is invalid.: FAIL
[ Triage 2017/02/20: P3 ]
Priority: -- → P3
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/340be2f71abf
[wpt PR 9400] - [css-align] justfy-items accepts 'legacy' and drops support for 'auto', a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/09992ffb6a0d
[wpt PR 9400]- Update wpt metadata, a=testonly
Whiteboard: [wptsync downstream] → [wptsync upstream error]
https://hg.mozilla.org/mozilla-central/rev/340be2f71abf
https://hg.mozilla.org/mozilla-central/rev/09992ffb6a0d
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
After backing out https://bugzilla.mozilla.org/show_bug.cgi?id=1443558#c4 the wpt tests started mass failing as you can see on this push https://goo.gl/Awm6eR  

I decided to backout all the changesets from the original push https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=5138dcf1eddd750c06e05a784f170b771ba58f60 because of this mass wpt failures.
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(bugs)
Resolution: FIXED → ---
Target Milestone: mozilla60 → ---
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/86368a236996
[wpt PR 9400] - [css-align] justfy-items accepts 'legacy' and drops support for 'auto', a=testonly
https://hg.mozilla.org/mozilla-central/rev/86368a236996
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Assignee: nobody → james
Flags: needinfo?(bugs)
You need to log in before you can comment on or make changes to this bug.