[FreeBSD] Primary X selection has been broken

RESOLVED DUPLICATE of bug 1447925

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1447925
a year ago
a year ago

People

(Reporter: bugmail, Assigned: stransky)

Tracking

({regression})

Trunk
All
Unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 fix-optional, firefox60 affected)

Details

Reporter

Description

a year ago
I'm afraid the changes introduced in bug #1417874 broke the primary X selection.
Revision 463d676df5da worked fine, whereas rev. 296dd5f8849a didn't. See also https://hg.mozilla.org//mozilla-central/pushloghtml?fromchange=c35272ba2006&tochange=296dd5f8849a

Steps to reproduce:
 1. start Firefox
 2. start an xterm
 3. mark some text in the xterm
 4. change focus to Firefox
 5. press middle mouse button on "URL Bar" or "Search Bar"

Expected results:
 The selected text should be pasted.

Actual results:
 It doesn't get pasted.

This even happens with a pristine profile and/or in safe mode. My test box runs FreeBSD 11-stable with current ports. GTK is v3.22.15. Tested with PWM and TWM.

Martin, maybe you could take a look at this once you're back? I'd be more than happy to run a few tests to further narrow down the cause or to help test patches.
Flags: needinfo?(stransky)
Assignee

Comment 1

a year ago
Sure. Can you please test with enabled xinput2? You need to set MOZ_USE_XINPUT2=1 env variable to have it enabled. Thanks.
Assignee: nobody → stransky
Flags: needinfo?(stransky) → needinfo?(bugmail)
Reporter

Comment 2

a year ago
Yes. That didn't seem to make a difference, though.
Flags: needinfo?(bugmail)
Assignee

Comment 3

a year ago
I'm unable to reproduce on Fedora 27 + twm + xterm, the selection works as expected. Can you run Firefox from terminal and check if there's any error message on console?
Flags: needinfo?(bugmail)
Assignee

Comment 4

a year ago
Jan, do you also see that? Is that reproducible on different desktop environment?
Flags: needinfo?(jbeich)
Assignee

Updated

a year ago
Summary: Primary X selection has been broken → [FreeBSD] Primary X selection has been broken
Reporter

Comment 5

a year ago
Ok, here we go. Trying to paste some text using middle mouse-click, I always get the some output on the console.
No matter whether I use a (non-working) build from a few days ago, or a (working) build from early November:

   (firefox:#####): Gdk-WARNING **: gdkproperty-x11.c:224 invalid X atom: -5784

This message appears exactly nine times right after each click. All tests were run using fresh profiles.

Funny enough, in the "Save Page as..." dialog, pasting from X_primary always seems to work as expected.

Oh, and "xinput --version" yields:
   xinput version 1.6.2
   XI version on server: 2.3
Flags: needinfo?(bugmail)

Comment 6

a year ago
FreeBSD 10.3 i386/11.1 amd64 jails, Firefox 60.0b4, Gtk 3.22.15, Xserver 1.19.6. I can't reproduce: middle click pastes PRIMARY but Shift + Insert pastes CLIPBOARD. Either one is consistent with other Gtk2/Gtk3 apps but not with XTerm[1].

[1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=188264
Flags: needinfo?(jbeich)

Comment 7

a year ago
I see non working X-Selection-Paste on NetBSD too (see bug 1447774), but in my case it depends on the selection owner: with xterm all is fine, with rxvt it does not work. Difference in past code, AFAICT, is the multitude of clipboard format that xterm offers, while rxvt only does XA_STRING. Similar symptom, but probably a different cause - or maybe the reason why it works for some but not others.
Assignee

Comment 8

a year ago
You can show content of the clipboard by xclip utility. For selection it may be:

xclip -o -t TARGETS -selection

please attach output of this command when you have selected clipboard content which can't be pasted to Firefox. Also please make sure you don't overwrite it by this command (you may need to type it to the terminal).
Flags: needinfo?(bugmail)

Comment 9

a year ago
I can NOT paste: 

 > xclip -o -t TARGETS -selection
TARGETS
STRING   
TEXT
COMPOUND_TEXT

... and this works:

 > xclip -o -t TARGETS -selection
UTF8_STRING
TEXT
COMPOUND_TEXT
STRING
LENGTH
LIST_LENGTH
TIMESTAMP
HOSTNAME  
IP_ADDRESS
USER
CLASS
NAME 
CLIENT_WINDOW
Flags: needinfo?(bugmail)
Thanks, looks like a variant of Bug 1447925, the patch attached there should also fix this bug.
See Also: → 1447925
Duplicate of this bug: 1447774
Priority: -- → P3
Depends on: 1447925
See https://bugzilla.mozilla.org/show_bug.cgi?id=1447925#c30 can you please check if the latest build fixes this bug for you?
Flags: needinfo?(martin)
Assignee

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1447925
Latest patch works for me, thanks!
Flags: needinfo?(martin)
You need to log in before you can comment on or make changes to this bug.