Site information window is cut off in Russian build if some windows were blocked

VERIFIED FIXED in Firefox 60

Status

()

defect
P2
normal
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: unghost, Assigned: prathiksha)

Tracking

unspecified
Firefox 60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 wontfix, firefox59 wontfix, firefox60 verified)

Details

Attachments

(2 attachments)

Posted image Screenshot of bug
STR:
1) Open a site which open popup window(s) in Russian build (e.g. http://www.popuptest.com/popuptest1.html )
2) Click on site information icon to open site information pop-up window

Expected result: Site information pop-up window is not cut off

Actual result: Site information pop-up window is cut off
Component: General → Site Identity and Permission Panels
Hmm, that doesn't look great, I wonder if there's a way we can limit the "Open Pop-up Windows" text to a maximum width so that it doesn't push the button out...
Blocks: 1331931
Priority: -- → P2
Assignee: nobody → prathikshaprasadsuman
Status: NEW → ASSIGNED
Comment on attachment 8955770 [details]
Bug 1437324 - Wrap popup permission indicator text in the Site Identity Panel when it exceeds the width of the panel.

https://reviewboard.mozilla.org/r/224834/#review230938

That seems to do the trick, thank you.

::: commit-message-426ef:1
(Diff revision 1)
> +Bug 1437324 -  Manage popup permission indicator text width in the Site Identity panel. r?johannh

Can you give this a little better commit message and/or description? I don't think I would be able to tell what is happening in this commit when reading it without context.

::: browser/themes/shared/controlcenter/panel.inc.css:335
(Diff revision 1)
>       should be right aligned with the section icon. */
>    margin-inline-start: calc(-1em - 16px);
>  }
>  
>  .identity-popup-permission-item {
> -  min-height: 24px;
> +  min-height: 25px;

I'm fine with this change, but why is it necessary? :)
Attachment #8955770 - Flags: review?(jhofmann) → review+
> >  .identity-popup-permission-item {
> > -  min-height: 24px;
> > +  min-height: 25px;
> 
> I'm fine with this change, but why is it necessary? :)

I reverted this change. Sorry about that. It previously looked to me like the indicator text overflowed out of the panel's length when it got wrapped into two lines. It now looks like it overflows out of the panel's length only if that string is long enough to wrap into three lines and I think that's unlikely to happen.
I'm using .textContent to set the indicator label text here instead of the "value" attribute because the text set using the "value" attribute does not wrap when it exceeds the width of the panel, which in turn pushes the menulist and half of the indicator text out of view. I hope this gives a little more context to the commit message.
This needs QA testing to ensure that the popup indicator text (the text next to the tiny arrow icon in attachment 8950021 [details]) and the menulist do not overflow and get pushed out of the site identity panel in locales like Russian.

STR is in the bug description.
Flags: qe-verify+
Pushed by prathikshaprasadsuman@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/232a67888d2f
Wrap popup permission indicator text in the Site Identity Panel when it exceeds the width of the panel. r=johannh
https://hg.mozilla.org/mozilla-central/rev/232a67888d2f
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Managed to reproduce the issue on Windows 10, x64 on Nightly 60.0a1 (2018-02-09) (64-бит) [Russian].

Fixed on Windows 10 x64, Ubuntu 16.04, Mac OSX Sierra: Nightly 60.0a1 (2018-03-12) (64-бит).

I am marking it as Verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.