Closed Bug 1437425 Opened 2 years ago Closed Last year

Intermittent PROCESS-CRASH |ARES6, tps | application crashed [@ __psynch_mutexwait + 0xa]

Categories

(Testing :: Talos, defect, P5, critical)

Version 3
defect

Tracking

(firefox-esr52 unaffected, firefox59 unaffected, firefox60 disabled, firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- disabled
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jmaher)

Details

(Keywords: crash, intermittent-failure)

Crash Data

Attachments

(2 files)

Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=161640178&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/A8Aj6_efS4GjWPCxf07hJw/runs/0/artifacts/public/logs/live_backing.log

8:48:56     INFO -  TEST-INFO | 2355: exit 0
18:48:56     INFO -  mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/ORZnva4-S-GDtkMr1VWUjA/artifacts/public/build/target.crashreporter-symbols.zip
18:49:10     INFO -  mozcrash Copy/paste: /Users/cltbld/tasks/task_1518395855/build/macosx64-minidump_stackwalk /var/folders/lp/yzl_q26s0b31h1_xskvs3rb800000w/T/tmp9MufHw/profile/minidumps/8FF1DCF4-A19D-4836-8AB9-09D2823CC469-browser.dmp /var/folders/lp/yzl_q26s0b31h1_xskvs3rb800000w/T/tmpCYI_bD
18:49:38     INFO -  mozcrash Saved minidump as /Users/cltbld/tasks/task_1518395855/build/blobber_upload_dir/8FF1DCF4-A19D-4836-8AB9-09D2823CC469-browser.dmp
18:49:38     INFO -  PROCESS-CRASH | tps | application crashed [@ __psynch_mutexwait + 0xa]
18:49:38     INFO -  Crash dump filename: /var/folders/lp/yzl_q26s0b31h1_xskvs3rb800000w/T/tmp9MufHw/profile/minidumps/8FF1DCF4-A19D-4836-8AB9-09D2823CC469-browser.dmp
18:49:38     INFO -  Operating system: Mac OS X
18:49:38     INFO -                    10.10.5 14F27
18:49:38     INFO -  CPU: amd64
18:49:38     INFO -       family 6 model 69 stepping 1
18:49:38     INFO -       4 CPUs
18:49:38     INFO -  GPU: UNKNOWN
18:49:38     INFO -  Crash reason:  EXC_BREAKPOINT / EXC_I386_BPT
18:49:38     INFO -  Crash address: 0x7fff908cf166
18:49:38     INFO -  Process uptime: 27 seconds
18:49:38     INFO -  Thread 0 (crashed)
18:49:38     INFO -   0  libsystem_kernel.dylib!__psynch_mutexwait + 0xa
18:49:38     INFO -      rax = 0x000000000200012d   rdx = 0x0000000000000000
18:49:38     INFO -      rcx = 0x00007fff52565948   rbx = 0x0000000000000203
18:49:38     INFO -      rsi = 0x0000000000000203   rdi = 0x00007fff52565d20
18:49:38     INFO -      rbp = 0x00007fff525659d0   rsp = 0x00007fff52565948
18:49:38     INFO -       r8 = 0x0000000000002060    r9 = 0x0000000000000000
18:49:38     INFO -      r10 = 0x0000000000018b08   r11 = 0x0000000000000246
18:49:38     INFO -      r12 = 0x00007fff52565d38   r13 = 0x0000000000000203
18:49:38     INFO -      r14 = 0x0000000000000000   r15 = 0x00007fff52565d20
18:49:38     INFO -      rip = 0x00007fff908cf166
18:49:38     INFO -      Found by: given as instruction pointer in context
18:49:38     INFO -   1  XUL!google_breakpad::ExceptionHandler::WriteMinidump(bool) [exception_handler.cc:8fae9e55fd403fdfa3b2db4ba496c68e519f38b6 : 298 + 0x5]
18:49:38     INFO -      rbp = 0x00007fff52565c60   rsp = 0x00007fff525659e0
18:49:38     INFO -      rip = 0x000000011143b857
18:49:38     INFO -      Found by: previous frame's frame pointer
18:49:38     INFO -   2  XUL!google_breakpad::ExceptionHandler::WriteMinidump(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&, bool, bool (*)(char const*, char const*, void*, bool), void*) [exception_handler.cc:8fae9e55fd403fdfa3b2db4ba496c68e519f38b6 : 313 + 0xb]
18:49:38     INFO -      rbx = 0x0000000000000001   rbp = 0x00007fff52565d90
18:49:38     INFO -      rsp = 0x00007fff52565c70   r14 = 0x00007fff52565c80
18:49:38     INFO -      r15 = 0x0000000000000000   rip = 0x000000011143b961
18:49:38     INFO -      Found by: call frame info
I see this on osx as well for a new benchmark ARES6- 

https://public-artifacts.taskcluster.net/TIbdPVmNQOKx7MeA9Kh6VQ/0/public/logs/live_backing.log


this seems to be forcing a browser shutdown/crash after timing out while waiting for the process to terminate.
Summary: Intermittent PROCESS-CRASH | tps | application crashed [@ __psynch_mutexwait + 0xa] → Intermittent PROCESS-CRASH |ARES6, tps | application crashed [@ __psynch_mutexwait + 0xa]
Comment on attachment 8953095 [details] [diff] [review]
do not run ares6 on osx

Review of attachment 8953095 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8953095 - Flags: review?(rwood) → review+
:jandem, we are unable to get ARES-6 running reliably on OSX- is this something that you think would be useful?  We have it running on linux/windows with the same setup.  We will need someone to look at this if we want it running on OSX.
Flags: needinfo?(jdemooij)
(In reply to Joel Maher ( :jmaher) (UTC-5) from comment #9)
> :jandem, we are unable to get ARES-6 running reliably on OSX

Hm do you know what the problem is exactly?

> We have it running on
> linux/windows with the same setup.  We will need someone to look at this if
> we want it running on OSX.

Hm Linux and Windows is probably okay.. I just don't wallpaper over a real bug/crash...
Flags: needinfo?(jdemooij) → needinfo?(jmaher)
I tried to get fresh crashes on try and failed:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e4b20749a16b0b625405760a7bff1a2a7543c610

let me enable this
Flags: needinfo?(jmaher)
ok, lets get this running again.
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8968584 - Flags: review?(rwood)
Attachment #8968584 - Flags: review?(rwood) → review+
https://hg.mozilla.org/mozilla-central/rev/22cce00037f9
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.