applet can't load (application/x-java-vm) unless Netscape 6 installed

RESOLVED INVALID

Status

RESOLVED INVALID
17 years ago
8 years ago

People

(Reporter: pcsien, Assigned: joe.chou)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Applets cannot load (always get the "click here after installing plugin") on my
system which does not have Netscape 6 installed. This happens on Windows 200 and
also Mac OS X (the ones I use). The dll's required are in the plugins directory
as needed but unless Netscape 6 is installed also, the applets do not load.

Comment 1

17 years ago
oji
Assignee: beppe → joe.chou
Component: Plug-ins → OJI
QA Contact: shrir → pmac

Comment 2

17 years ago
PC Sien, what URL are you accessing?
(Reporter)

Comment 3

17 years ago
This occurs when I try to load the Weblogic Console when accessing the console
app which is installed with Weblogic 6.0
Assuming the that weblogic is installed on your localhost you can access the
console with the follwoing:
http://localhost:7001/console

Comment 4

17 years ago
Can you reproduce this problem using a different Java applet? You're not likely
to find anybody with Weblogic here.
(Reporter)

Comment 5

17 years ago
I have not tried with a different applet.
You can download an 30 day evaluation version of Weblogic 6.0 from the www.bea.com.
Install the server with the default values. Start the server.
The problem will show when you try to load the console app.

Comment 6

17 years ago
This applet seems accessible to all, and uses the mysterious 'x-java-vm'
content-type.  I'm testing it from a linux box (RedHat), latest release of
Mozilla (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529)

http://www.javapowered.com/slider/slider.html
(Assignee)

Comment 7

17 years ago
Mac bug, re-assign to Patrick.
Assignee: joe.chou → beard

Comment 8

17 years ago
I think I got it!  I had been using the Netscape 4 plugin that comes with Sun's
Java Runtime package.  I noticed someone running Mozilla publically displayed
their 'about:plugins' settings on a webpage (?) and had both the ns4 and ns6
versions of java running in that report.

I tried switching my java plugin to point to the ns600 file
'libjavaplugin_oji.so' instead of where I originally had it: the ns4 file
'javaplugin.so'.  Everything worked.  'nuff said.  :)  Mozilla is more
compatible with Java for Netscape 6.0 than Java for Netscape 4.0.

...not much to be done about it unless someone wants to put an updated
Mozilla-Java tutorial up somewhere...

Comment 9

17 years ago
OK, Using NS4 Java Plugin isn't supposed to work here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 10

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: beard → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.