Closed Bug 1437807 Opened 2 years ago Closed 2 years ago

Enable browser_console_addonsdk_loader_exception.js in new frontend

Categories

(DevTools :: Console, enhancement, P1)

enhancement

Tracking

(firefox60 fixed)

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: nchevobbe, Assigned: miker)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 file)

No description provided.
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Priority: -- → P2
Whiteboard: [newconsole-mvp]
Severity: normal → enhancement
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Depends on: 1437844
OS: Unspecified → All
Priority: P2 → P1
Hardware: Unspecified → All
Comment on attachment 8956070 [details]
Bug 1437807 - Enable browser_console_addonsdk_loader_exception.js in new frontend

https://reviewboard.mozilla.org/r/225012/#review231234

Looks good Mike, thanks. 
The runtime on debug builds seems to be around 10-15 seconds, so removing the requestLongerTimeout as you did should be fine.

::: devtools/client/webconsole/new-console-output/test/mochitest/browser_console_addonsdk_loader_exception.js:8
(Diff revision 2)
>  /* Any copyright is dedicated to the Public Domain.
>   * http://creativecommons.org/publicdomain/zero/1.0/ */
>  
>  /* import-globals-from head.js */
>  
>  // Check that exceptions from scripts loaded with the addon-sdk loader are

The addon-sdk loader was completely copied over to devtools, so "addon-sdk loader" will make less and less sense in the future. 
Should we file a follow up to rename everything that refers to addonsdk loader (including the test name) to devtools loader?
Attachment #8956070 - Flags: review?(jdescottes) → review+
(In reply to Julian Descottes [:jdescottes][:julian] from comment #3)

> The addon-sdk loader was completely copied over to devtools, so "addon-sdk
> loader" will make less and less sense in the future. 
> Should we file a follow up to rename everything that refers to addonsdk
> loader (including the test name) to devtools loader?

Bug 1443457 logged.
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c132fa7abc4b
Enable browser_console_addonsdk_loader_exception.js in new frontend r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/c132fa7abc4b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.