Closed Bug 1437808 Opened 3 years ago Closed 3 months ago

[Tablets] Google images results open the website, not the image

Categories

(Web Compatibility :: Mobile, defect, P3)

ARM
Android
defect

Tracking

(platform-rel ?, fennec?, firefox58 affected, firefox59 affected, firefox60 affected)

RESOLVED WORKSFORME
Tracking Status
platform-rel --- ?
fennec ? ---
firefox58 --- affected
firefox59 --- affected
firefox60 --- affected

People

(Reporter: oana.horvath, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [platform-rel-Google][notcontactready])

Devices:
*Tablets only* 
Samsung Galaxy Tab 3 (Android 7.0)
Huawei MediaPad M2 (Android 5.1.1)

Build: Nightly 60.0a1 (2018-02-13);

Steps to reproduce:
1. Search for a term an tap the Images results category on Google.
2. Tap on an image.

Expected result:
The image opens, enlarged.

Actual result:
The website source of the image is opened.
This seems like TE.
Component: General → Mobile
Product: Firefox for Android → Tech Evangelism
platform-rel: --- → ?
Whiteboard: [platform-rel-Google][needstriage]
Tom, do we have this issue tracked in our GWS Tier 1 work?
Blocks: 975444
Flags: needinfo?(twisniewski)
Priority: -- → P1
No, and it doesn't appear to be a GWS tier-1 issue, as I can only reproduce this when using the stock Firefox UA, not when spoofing as Chrome Mobile for tablets.

In fact this appears to be intentional by design, as spoofing Chrome as Firefox yields the same result.

Indeed, here is the related markup for one of the thumbnails:

> <a class="_dfb" href="/url?q=http://www.tajalexandher.com/2017/03/01/long-term-faith-vs-short-term-faith/&amp;sa=U&amp;ved=0ahUKEwjgwpvwtKjZAhWF8YMKHSarCfoQwW4IDSgAMAE&amp;usg=AOvVaw0sHFTQd8Fg5pw0rOpQsbq0">
>   <img class="_dfb" src="https://encrypted-tbn0.gstatic.com/images?q=tbn:ANd9GcQ5ReoZSv40hJ74LCmVX8eEXKSAT0fcNOu3z7YFay6kznj--JGKAj_RqHfv" alt="Image result for term" height="75px">
> </a>

There are no JS event listeners, so tapping the image just funnels the user to the site via Google's link redirector.
Flags: needinfo?(twisniewski)
OK, thanks. I don't think there's much to do here, if our goal is to get Tier 1 Search.
Priority: P1 → P3
Whiteboard: [platform-rel-Google][needstriage] → [platform-rel-Google][notcontactready]
Hoping this will be fixed by getting tier 1 support
Product: Tech Evangelism → Web Compatibility

I can reproduce the issue on my side, for me the image opens now enlarged, similar to Chrome.
https://prnt.sc/xr6k9v

Tested with:
Browser / Version: Firefox Nightly 210127 (🦎 87.0a1-202101260925428)
Operating System: Huawei MediaPad T5 (Android 8.0.0) - 1920 x 1200 pixels, 16:10 ratio (~224 ppi density)

Oana can you still reproduce it on your side?

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(oana.horvath)
Resolution: --- → WORKSFORME

(In reply to Oana Arbuzov [:oanaarbuzov] from comment #6)

Oana can you still reproduce it on your side?
Verified as well with the latest Nightly build (2/2) and it doesn't reproduce anymore. Thanks!

Flags: needinfo?(oana.horvath)
You need to log in before you can comment on or make changes to this bug.