Closed Bug 1437845 Opened 2 years ago Closed 2 years ago

Enable browser_console_dead_objects.js in new frontend

Categories

(DevTools :: Console, enhancement, P1)

enhancement

Tracking

(firefox60 fixed)

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: nchevobbe, Assigned: miker)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 file)

No description provided.
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Priority: -- → P2
Whiteboard: [newconsole-mvp]
Severity: normal → enhancement
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
OS: Unspecified → All
Priority: P2 → P1
Hardware: Unspecified → All
We can use this to get a dead object:
var s = Cu.Sandbox(null); Cu.nukeSandbox(s); s;
Attachment #8955114 - Flags: review?(bgrinstead)
Comment on attachment 8955114 [details]
Bug 1437845 - Enable browser_console_dead_objects.js in new frontend

https://reviewboard.mozilla.org/r/224270/#review230304

Thanks, this is much nicer (and glad it's now working in e10s)!
Attachment #8955114 - Flags: review?(bgrinstead) → review+
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/98f2913853d4
Enable browser_console_dead_objects.js in new frontend r=bgrins
https://hg.mozilla.org/mozilla-central/rev/98f2913853d4
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Product: Firefox → DevTools
Duplicate of this bug: 1243994
You need to log in before you can comment on or make changes to this bug.