Closed Bug 1437967 Opened 2 years ago Closed 2 years ago

"Microsoft Translator" image in "Translations by" checkbox in translate/language preferences is vertically stretched, has wrong aspect ratio

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: adw, Assigned: adw)

Details

Attachments

(3 files)

See the attached screenshot.  The image's width is specified as 70px in preferences.css, and the width is indeed 70px, but the height is stretched because the parent hbox has the default stretch align.  I think it's been like this forever.
I just noticed there's also no space between "Translate web content." and "Translations by".  The period in the first sentence is right next to the T in the second.  I added a <separator>, which is already used to space out the image from the text.
Comment on attachment 8950672 [details]
Bug 1437967 - "Microsoft Translator" image in "Translations by" checkbox in translate/language preferences is vertically stretched, has wrong aspect ratio.

https://reviewboard.mozilla.org/r/219926/#review225750
Attachment #8950672 - Flags: review?(jaws) → review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35d9bc4727d2
"Microsoft Translator" image in "Translations by" checkbox in translate/language preferences is vertically stretched, has wrong aspect ratio. r=jaws
https://hg.mozilla.org/mozilla-central/rev/35d9bc4727d2
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Attached patch Beta patchSplinter Review
Approval Request Comment
[Feature/Bug causing the regression]:
The translation attribution was added in bug 1022856, but it looks like this bug started happening when the preferences UI was moved in-content.

[User impact if declined]:
No big deal, they'll continue to see a stretched/warped logo for another release

[Is this code covered by automated tests?]:
No need, this is only a visual change.  Prefs UI has tests in general though

[Has the fix been verified in Nightly?]:
No

[Needs manual test from QE? If yes, steps to reproduce]:
No

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
Very small patch, only a cosmetic change

[String changes made/needed]:
None
Attachment #8951118 - Flags: approval-mozilla-beta?
Comment on attachment 8951118 [details] [diff] [review]
Beta patch

Low risk fix, Beta59+
Attachment #8951118 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.