Closed Bug 1438007 Opened 2 years ago Closed 2 years ago

regression: Webrender errors on r/DestinyTheGame (border clipping)

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1455839
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected

People

(Reporter: hooloovoo79, Assigned: gw)

References

(Blocks 1 open bug, )

Details

(Keywords: correctness, nightly-community, regression)

Attachments

(3 files)

With Webrender enabled, there are rendering errors with elements on the right hand side of r/DestinyTheGame.
There are some css transforms on elements that seem to end up being processed multiple times or something, leading to additional elements that shouldn't be there being rendered.
These errors also then end up being rendered in the chrome of the browser window.
None of this occurs with webrender off.

https://www.reddit.com/r/DestinyTheGame/

Will attach screenshots of problems I'm seeing.
Webrender error being painted in the browser chrome
Webrender creating multiple additional elements from a css transform
Thanks!
Confirmed in Nightly 60 x64 20180213100127 de_DE @ Debian Testing (KDE, Radeon RX480).
fresh profile: gfx.webrender.all
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → All
I can only reproduce the "drawn on chrome" issue with https://addons.mozilla.org/en-US/firefox/addon/quantum-lights-dynamic/.

History of this regression:

1) additional lines
mozregression --good 2017-11-15 --bad 2018-01-10 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://www.reddit.com/r/DestinyTheGame/"
> 13:29.07 INFO: Last good revision: 3abc6abd34bf81eb3bd29f21630cbefa2f43947b
> 13:29.07 INFO: First bad revision: 9f8cde87eaa7a7b164c999a369b4835c7ec68e62
> 13:29.07 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=3abc6abd34bf81eb3bd29f21630cbefa2f43947b&tochange=9f8cde87eaa7a7b164c999a369b4835c7ec68e62

(2017-12-05)
> 52277221fade	Kartikaya Gupta — Bug 1422317 - Update webrender to commit b7714b1d4348c00682b5643ea0e3f0b15adaeda5. r=jrmuizel

try builds are gone

-----

2) changed to filled squares
mozregression --good 2017-11-15 --bad 2018-01-10 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrendest.enabled:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://www.reddit.com/r/DestinyTheGame/"
> 11:25.36 INFO: Last good revision: c174ef283f5561aa3cf24b1d014b5f62dcd5ccd4
> 11:25.36 INFO: First bad revision: 8ccb0e9d9bbeeed7d7e4474849debd7d21b65971
> 11:25.36 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=c174ef283f5561aa3cf24b1d014b5f62dcd5ccd4&tochange=8ccb0e9d9bbeeed7d7e4474849debd7d21b65971

(2018-01-08)
> da9b75fc0866	Kartikaya Gupta — Bug 1426116 - Update webrender to commit a422f907be948b92bf5c7003a01f7744391a795e. r=jrmuizel

try builds are gone

-----

3) back to (1)
mozregression --good 2018-01-12 --bad 2018-02-13 --pref gfx.webrender.all:true startup.homepage_welcome_url:"https://www.reddit.com/r/DestinyTheGame/"
> 10:49.90 INFO: Last good revision: 1a4f40cd0bea7855f76b2237819e07e89fd89d75
> 10:49.90 INFO: First bad revision: 6d9dc65ca0ed1a374dde7592a5b4191a7a10759c
> 10:49.90 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=1a4f40cd0bea7855f76b2237819e07e89fd89d75&tochange=6d9dc65ca0ed1a374dde7592a5b4191a7a10759c

(2018-01-20)
> d1a22efb9e43	Kartikaya Gupta — Bug 1430829 - Update webrender to commit e9269c7e06e20363be0b2a2a1be98d292ff7acca. r=jrmuizel
https://github.com/servo/webrender/compare/5fae1ac37d9c9adf45601cfad83b31a3d6bafd68...e9269c7e06e20363be0b2a2a1be98d292ff7acca
Blocks: 1422317
Keywords: regression
Summary: Webrender errors on r/DestinyTheGame → regression: Webrender errors on r/DestinyTheGame
I forgot that I was using a lightweight theme and that might be part of the problem. For information (and something maybe easier on the eyes), I am using "Mac Finish" by unknwn_sk8r.
(In reply to John from comment #2)
> Webrender creating multiple additional elements from a css transform

I can reproduce this. I tried a few builds from mozregression between 2017-10-01 and today and every build rendered it differently. It's changed too many times, I don't think a regression range will be very meaningful.
Assignee: nobody → gwatson
Priority: -- → P1
It's likely this will be fixed by the patch mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=1429537.
Attached file Reduced test case
This is still broken. Here's a reduced test case.
Yes, I am getting the artifacts also. I'm using an nVidia 1080 TI.
See Also: → 1446171
Summary: regression: Webrender errors on r/DestinyTheGame → regression: Webrender errors on r/DestinyTheGame (border clipping)
bug 1457891:
> WR @ 4b65822a2f7e1fed246a492f9fe193ede2f37d74
mozregression --repo try --launch c02f2c9507c6524a05a04c40b78b8c741e7a5010 --pref gfx.webrender.all:true startup.homepage_welcome_url:'https://old.reddit.com/r/DestinyTheGame/|https://bug1438007.bmoattachments.org/attachment.cgi?id=8962461'
bad

> WR @ a2dec3b0aea6b719325946a1b855df49ab33a3c9
mozregression --repo try --launch 9dab22f0fa803da8a1267b36bc32f026ab5b78bc --pref gfx.webrender.all:true startup.homepage_welcome_url:'https://old.reddit.com/r/DestinyTheGame/|https://bug1438007.bmoattachments.org/attachment.cgi?id=8962461'
good

Fix range: https://github.com/servo/webrender/compare/4b65822a2f7e1fed246a492f9fe193ede2f37d74...a2dec3b0aea6b719325946a1b855df49ab33a3c9

Most likely servo/webrender#2707.

Thanks!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1455839
You need to log in before you can comment on or make changes to this bug.