page with <embed> flash in <object> is overrun with black when scrolled then reloaded (or Back / Forward)

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
--
major
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Brian Rogers, Assigned: Kevin McCluskey (gone))

Tracking

({shockwave, testcase})

Trunk
x86
Windows 2000
shockwave, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When there is a shockwave flash video embedded inside an object tag, and the
page gets loaded with a scroll position (such as scrolling, then reload, or do
back/forward), there is a whole mess of black over most of the page on the
initial paint.  Repaints after that point are correct, so scrolling displays new
content correctly.

This only happens if the scroll position is set at the time of the initial
reflow.  If the document loads too slow, you don't see it.  I will attach a
simplified testcase.

I'm not sure about the component, but my first guess is Views.  I'm marking this
as major severity because it will most often be triggered by ads, and that's
quite annoying.
(Reporter)

Comment 1

16 years ago
Created attachment 83229 [details]
testcase

Load this file, scroll down, then reload, and you should see the problem.

If you take out the <object> tag, it won't happen.
(Reporter)

Comment 2

16 years ago
Oh, forgot to say, I saw this on Mozilla 1.0RC2.
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0, shockwave, testcase
(Reporter)

Comment 3

16 years ago
This problem went away in RC3.  Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.