If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[BETA FEATURE] "About Apprunnerø" from Apple menu needs updating

VERIFIED FIXED in M15

Status

SeaMonkey
General
P1
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Eli Goldberg, Assigned: saari (gone))

Tracking

({helpwanted, pp})

Trunk
PowerPC
Mac System 8.5
helpwanted, pp

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-] 1 day, URL)

(Reporter)

Updated

18 years ago
Group: netscapeconfidential?
(Reporter)

Description

18 years ago
<Marking as confidential so that I can enter bug content.>
(Reporter)

Comment 1

18 years ago
I assume that our product won't be called "Apprunner". ;)

Therefore, the Mac OS "About Apprunner..." item on the Apple menu should probably
say something like:

	Mozilla builds: "About Mozilla..."
	Netscape commercial builds: "About Netscape 2000..."
(Reporter)

Updated

18 years ago
Summary: [PP] "About Apprunner..." from Apple menu → [PP] "About Apprunner..." from Apple menu needs updating
(Reporter)

Updated

18 years ago
Summary: [PP] "About Apprunner..." from Apple menu needs updating → [PP] [BETA] "About Apprunner..." from Apple menu needs updating
(Reporter)

Comment 2

18 years ago
I assume that our product won't be called "Apprunner". ;)

Therefore, the Mac OS "About Apprunner..." item on the Apple menu should probably
say something like:

	Mozilla builds: "About Mozilla..."
	Netscape commercial builds: "About Netscape 2000..."

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Priority: P3 → P5
Target Milestone: M15

Comment 3

18 years ago
targetting p5 for m15

Comment 4

18 years ago
Should be "Netscape 2001" instead of Netscape 2000.

Updated

18 years ago
Target Milestone: M15 → M14

Comment 5

18 years ago
This is from saari's hard coding of the menu in nsMenuBar and needs to be
resolved into someting that can be adjusted during the build process

Updated

18 years ago
Summary: [PP] [BETA] "About Apprunner..." from Apple menu needs updating → [PP BETA FEATURE] "About Apprunner..." from Apple menu needs updating

Comment 6

18 years ago
featuring

Updated

18 years ago
Blocks: 15681

Comment 7

18 years ago
More menu related bugs being passed to pinkerton
Assignee: sdagley → pinkerton
Status: ASSIGNED → NEW
mac native, over to saari
Assignee: pinkerton → saari
(Assignee)

Comment 9

18 years ago
I don't think this should be a beta1 bug, but someone might disagree
Status: NEW → ASSIGNED
Keywords: beta1
Whiteboard: Should be beta 1?
(Reporter)

Comment 10

18 years ago
I do, on the grounds that I haven't seen Beta software before that doesn't even 
have the correct product name in the About menu.

Comment 11

18 years ago
PDT+
Whiteboard: Should be beta 1? → [PDT+]

Comment 12

18 years ago
Name should be Netscape 2001

Updated

18 years ago
Blocks: 26981

Updated

18 years ago
No longer blocks: 26981
(Assignee)

Comment 13

18 years ago
There are so many more important things for me to be working on (Yes, they are 
all PDT+ too).

I suggest you get someone else to do this if you want it for M14. Personally, I 
don't think this even comes close to a PDT+
Keywords: helpwanted
(Assignee)

Comment 14

18 years ago
Removing PDT+ for reconsideration
Whiteboard: [PDT+]
(Assignee)

Comment 15

18 years ago
*** Bug 6000 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
Putting on PDT- radar for beta1.  This is not critical to beta1.
Whiteboard: [PDT-]
(Assignee)

Comment 17

18 years ago
M15
Target Milestone: M14 → M15
(Reporter)

Updated

18 years ago
Summary: [PP BETA FEATURE] "About Apprunner..." from Apple menu needs updating → [PP BETA FEATURE] "About Apprunnerø" from Apple menu needs updating
(Reporter)

Comment 18

18 years ago
*** Bug 32084 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Priority: P5 → P1
Whiteboard: [PDT-] → [PDT-] 1 day
(Reporter)

Comment 19

18 years ago
Per this morning's press release announcing the official product name (Netscape 
6), removing the Confidential flag from this bug.
Group: netscapeconfidential?

Comment 20

18 years ago
... Thankyou, Eli.
Keywords: pp
Summary: [PP BETA FEATURE] "About Apprunnerø" from Apple menu needs updating → [BETA FEATURE] "About Apprunnerø" from Apple menu needs updating
(Assignee)

Comment 21

18 years ago
Someone updated it to read Mozilla. I just checked in code to make it actually 

work.

(Assignee)

Comment 22

18 years ago
Fixed. If the tag changes from Mozilla to Netscape in the help menu item 

About X, then it shall be so in the Apple menu as well.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 23

18 years ago
Verified fixed in 4/11/2000 AM build. The ellipses (...) are missing, but I can't 
find any evidence in the UI guidelines that they're in fact necessary, or a 
meaning of their presence in other Mac apps.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 24

18 years ago
[To be clear, yes, I did check both the Mozilla & Netscape builds to confirm that 
they have 'About <build type>' correct in both.]
(Assignee)

Comment 25

18 years ago
The meaning of the ellipses in a menu item is that it will bring up a dialog for 
further interaction.

I can add that if you think it is appropriate. The about box is sort of a grey 
area IMO.
(Reporter)

Comment 26

18 years ago
Yes. 

(Rather, going through a sample of a half-dozen application dialogs, that meaning 
isn't actually respected, and about boxes with no further interaction frequently 
use ellipses anyway.)

I'd personally prefer the ellipses, but agree with sfraser that there's no need 
to divert yourself from real work to do it. thanks!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.