Closed Bug 1438157 Opened 2 years ago Closed 2 years ago

Make EventUtils.synthesizeKey*()'s second argument optional

Categories

(Core :: DOM: UI Events & Focus Handling, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Most callers of synthesizeKey() specifies {} to the second argument. So, it should be optional argument.
Priority: -- → P2
Comment on attachment 8951522 [details]
Bug 1438157 - part 1: Make EventUtils.synthesizeKey()'s second argument, aEvent, optional

https://reviewboard.mozilla.org/r/220278/#review227042
Attachment #8951522 - Flags: review?(bugs) → review+
Comment on attachment 8951523 [details]
Bug 1438157 - part 2: Remove unnecessary second argument of EventUtils.synthesizeKey()

https://reviewboard.mozilla.org/r/220280/#review227046
Attachment #8951523 - Flags: review?(bugs) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 14d5eb0e7cc73e1860cf19e54106147d50df3c32 -d 34d3b357c867: rebasing 447924:14d5eb0e7cc7 "Bug 1438157 - part 1: Make EventUtils.synthesizeKey()'s second argument, aEvent, optional r=smaug"
rebasing 447925:20866fa95f46 "Bug 1438157 - part 2: Remove unnecessary second argument of EventUtils.synthesizeKey() r=smaug" (tip)
merging browser/base/content/test/general/browser_keywordBookmarklets.js
merging browser/base/content/test/urlbar/browser_autocomplete_enter_race.js
merging browser/base/content/test/urlbar/browser_urlbar_remove_match.js
merging devtools/client/storage/test/head.js
merging dom/events/test/test_dom_keyboard_event.html
merging toolkit/components/passwordmgr/test/browser/browser_formless_submit_chrome.js
merging toolkit/components/satchel/test/test_popup_enter_event.html
merging toolkit/content/tests/browser/browser_bug295977_autoscroll_overflow.js
merging toolkit/content/tests/chrome/test_autocomplete_mac_caret.xul
merging toolkit/content/tests/mochitest/test_autocomplete_change_after_focus.html
warning: conflicts while merging browser/base/content/test/urlbar/browser_autocomplete_enter_race.js! (edit, then use 'hg resolve --mark')
warning: conflicts while merging dom/events/test/test_dom_keyboard_event.html! (edit, then use 'hg resolve --mark')
warning: conflicts while merging toolkit/content/tests/chrome/test_autocomplete_mac_caret.xul! (edit, then use 'hg resolve --mark')
warning: conflicts while merging toolkit/content/tests/mochitest/test_autocomplete_change_after_focus.html! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/a9313b86c72f
part 1: Make EventUtils.synthesizeKey()'s second argument, aEvent, optional r=smaug
https://hg.mozilla.org/integration/autoland/rev/50d6fe2d0bca
part 2: Remove unnecessary second argument of EventUtils.synthesizeKey() r=smaug
https://hg.mozilla.org/mozilla-central/rev/a9313b86c72f
https://hg.mozilla.org/mozilla-central/rev/50d6fe2d0bca
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Duplicate of this bug: 528170
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.