Closed Bug 1438180 Opened 2 years ago Closed 2 years ago

"Show search suggestions in address bar results" checkbox from the about:preferences#search page has a misleading behavior

Categories

(Firefox :: Preferences, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- wontfix
firefox59 + wontfix
firefox60 --- verified

People

(Reporter: emilghitta, Assigned: Gijs)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Attachments

(2 files)

Attached image issue.gif
[Affected versions]:
60.0a1 (BuildId:20180213220104)
59.0b9 (BuildId:20180209162511)
58.0.2 (BuildId:20180206200532)

[Unaffected versions]:
52.6.0 esr (BuildId:20180118122319)

[Affected platforms]:
Windows 10 64bit.
macOS 10.13.
Ubuntu 16.04 64bit.

[Steps to reproduce]:
1. Launch Firefox with a clean profile.
2. Access the about:preferences#search page.
3. Untick the "Provide search suggestions" checkbox.
4. Restart Firefox.
5. Access the about:preferences#search page.

[Expected result]:
The following checkboxes are displayed garyed out and unticked:
- "Show search suggestions in address bar results".
- "Show search suggestions ahead of browsing history in address bar results".

[Actual result]:
The "Show search suggestions in address bar results" checkbox is displayed ticked and grayed out.


[Regression range]:
This is a regression:

Last good revision: 5c50e8581fedf2ef3a218574f705c71cc20e2cd8
First bad revision: 62517cf482ae592f7d71afb6d2819c7d7801615c

Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5c50e8581fedf2ef3a218574f705c71cc20e2cd8&tochange=62517cf482ae592f7d71afb6d2819c7d7801615c

[Note]

Please note that the "Show search suggestions ahead of browsing history in address bar results" checkbox is displayed under the "Default Search Engine" only in Nightly for the moment (per bug 1432716).

For further information regarding this issue please observe the attached screencast.
Hi Mark!

It seems that mozregression pointed out Bug 1393437.

Can you please have a look into this?

Thanks a lot!
Flags: needinfo?(standard8)
A faster way to reproduce this is to just close preferences & re-open it, although that doesn't always reproduce in latest nightly from the looks of it.

I've double-checked and the regression does seem to be bug 1393437.

However, I'm confused as I'm only adding a new preferences field, and not modifying anything else.

It seems to be the state of "Show search suggestions in address bar results" after restart is reflecting its saved value.

Since I don't normally do much preferences, I'm a bit confused. Need-info to Jared/Gijs to see if they have any ideas.
Flags: needinfo?(standard8)
Flags: needinfo?(jaws)
Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8951692 [details]
Bug 1438180 - don't update the url bar search suggestions pref directly,

I'm not a Firefox peer, so I can't grant r+, but this fix seems reasonable to me.
Attachment #8951692 - Flags: review?(myk) → feedback+
Duplicate of this bug: 1439033
Blocks: 1393437
this will be worth an uplift.
Priority: -- → P1
Whiteboard: [fxsearch]
[Tracking Requested - why for this release]:
I think we need to avoid shipping this if we can.
Comment on attachment 8951692 [details]
Bug 1438180 - don't update the url bar search suggestions pref directly,

https://reviewboard.mozilla.org/r/220976/#review227920
Attachment #8951692 - Flags: review?(jaws) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ba1d6f897a92
don't update the url bar search suggestions pref directly, r=jaws,f=myk
https://hg.mozilla.org/mozilla-central/rev/ba1d6f897a92
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Please nominate this for Beta approval when you get a chance. Also, let's get QE to verify the fix on Nightly.
Flags: qe-verify+
Flags: needinfo?(gijskruitbosch+bugs)
This issue is verified fixed using Firefox 60.0a1 (BuildId:20180221220150) on Windows 10 64bit, macOS 10.13.3 and Ubuntu 16.04 64bit. 

Leaving the qe-verify+ flag until this issue is verified in beta as well.
Status: RESOLVED → VERIFIED
Comment on attachment 8951692 [details]
Bug 1438180 - don't update the url bar search suggestions pref directly,

Approval Request Comment
[Feature/Bug causing the regression]: race condition that is apparently triggered by bug 1393437
[User impact if declined]: prefs don't behave the way they should
[Is this code covered by automated tests?]: apparently not in a way that catches this
[Has the fix been verified in Nightly?]: not yet.
[Needs manual test from QE? If yes, steps to reproduce]: see comment 0 and comment 2
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: single-line change that's been looked at by 3 people by now, will only affect this preference and, tbh, at this point it'd be hard to make the behaviour of this UI pref a lot worse...
[String changes made/needed]: no
Flags: needinfo?(gijskruitbosch+bugs)
Attachment #8951692 - Flags: approval-mozilla-beta?
(In reply to :Gijs from comment #13)
> [Has the fix been verified in Nightly?]: not yet.

Err, sorry, I hadn't seen comment 12 - yes, it's been verified! :-)
Comment on attachment 8951692 [details]
Bug 1438180 - don't update the url bar search suggestions pref directly,

Fix for a confusing UI issue, verified on Nightly already. Taking for 59b12.
Attachment #8951692 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have reproduced this issue using Firefox  60.0a1 (2018.02.14) on Win 8.1 x64.
I can confirm this issue is fixed, I verified using Firefox 59.0b12 on Windows 8.1 x64, Ubuntu 14.04 x64 and Mac OS X 10.13.4.
Flags: qe-verify+
No longer depends on: 1440832
Retroactive tracking in case this reopens. Which I doubt will happen, but hey.
Depends on: 1443229
See Also: → 1444158
See Also: → 1524995
You need to log in before you can comment on or make changes to this bug.