Closed Bug 1438317 Opened 2 years ago Closed Last year

"Indexing messages. Determining which messages to index" stuck on local folder never ends. Modest CPU - 7-10%. Error console "Observed header that claims to be gloda indexed but that gloda has never heard of during compaction"

Categories

(MailNews Core :: Database, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1362483

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: perf)

Nothing reproducible nor steps - just want to get this on the record.

"Determining which messages to index" stuck on a local folder X, and eating CPU (7%).  I did a repair on the folder and it went to the next folder Y and had the same problem.  Nothing noteworthy in activity manager.  (I've only seen this happen before with imap accounts) 

I don't konw the cause, but within an hour prior to seeing the dialog, automatic compact had run.
See Also: → 1310948
Just seen again. Same behavior - "I did a repair on the folder and it went to the next folder Y and had the same problem." In error console I see 

2018-06-16 11:17:04	gloda.index_msg	WARN	Observed header that claims to be gloda indexed but that gloda has never heard of during compaction. In folder: mailbox://nobody@Local%20Folders/moz/moz0-session sketchy key: 1029194 subject: [Bug 582005] Session Restore negatively impacts startup time based on the number of tabs loaded

I deleted the message in question (actually I deleted the entire thread), and the error console changed such that the subject is blank, but same key, and same folder

2018-06-16 11:33:35	gloda.index_msg	WARN	Observed header that claims to be gloda indexed but that gloda has never heard of during compaction. In folder: mailbox://nobody@Local%20Folders/moz/moz0-session sketchy key: 1029194 subject: 

And when I repaired the folder it changed to being stuck on another folder in the list. 

The circumstances leading up to this are not remarkable but I was doing extensive message folder maintenance, moving messages and threads from various "open message in converation" to various local and imap folders. But no activity in any of the local folders on which indexing got stuck.  

This is very much like bug 1406653
See Also: → 1406653
Summary: "Indexing messages. Determining which messages to index" on local folder never ends. → "Indexing messages. Determining which messages to index" stuck on local folder never ends. Modest CPU - 7-10%. Error console "Observed header that claims to be gloda indexed but that gloda has never heard of during compaction"
Seen again today ... after compact.  Using nightly build.
no sense keeping 3 bugs open
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1362483
You need to log in before you can comment on or make changes to this bug.