ibiblio.org - Moz refuses to download .TBZ2 file properly (Insists that it is a text file)

RESOLVED DUPLICATE of bug 148525

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 148525
16 years ago
3 years ago

People

(Reporter: Charles N. Burns, Unassigned)

Tracking

Details

(Whiteboard: [mime type], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

When attempting to download a .TBZ2 file, specifically an ISO of Gentoo Linux,
Moz does one of two things:
1) If you "left-click" on the file, Mozilla displays it as text.
2) If you "right-click" and select "Save link target as...", Mozilla will offer
to save it, but only as a text file. It appends a ".txt" extention on top of the
".TBZ2" and the "Save as type" dropmenu has no option but text. Mozilla DOES NOT
try to interpret the data as text while downloading (like an ASCII FTP
download); the file downloaded is not corrupt. Additionally, the extention can
be manually deleted from the filename prior to download (as I did in my download
test).

Reproducible: Always
Steps to Reproduce:
1. Go to: http://www.ibiblio.org/gentoo/releases/build/1.2/
2. Download your choice of .TBZ2 file.


Expected Results:  Mozilla should download the file without modification using
either download method.

- Perhaps Mozilla's interpretation of the file as text has something to do with
the fact that the extention begins with 't'

- I know that I can probably set up .TBZ2's properly in Mozilla, but users
shouldn't really have to.

- As tired as you are all probably of hearing it, we users really do appreciate
your development time and skill.
Sorry, this is not a Mozilla bug.  The server sends:

Content-type: text/plain

for this file.  Mozilla then follows the HTTP spec and shows it as text...

Over to evangelism so someone will contact the server admins and ask them to fix
their configuration (multiple such mails cannot hurt.  :) )
Assignee: blaker → doron
Status: UNCONFIRMED → NEW
Component: Download Manager → US General
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: sairuh → zach
Hardware: PC → All
Version: other → unspecified

Updated

15 years ago
Summary: Moz refuses to download .TBZ2 file properly (Insists that it is a text file) → ibiblio.org - Moz refuses to download .TBZ2 file properly (Insists that it is a text file)
Whiteboard: [mime type]

Comment 2

15 years ago
This is a dupe of #148525.

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 148525 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.