Content in Preferences > Advanced is cut off in mac Retina display

RESOLVED FIXED in Thunderbird 60.0

Status

defect
RESOLVED FIXED
a year ago
9 months ago

People

(Reporter: tchevalier, Assigned: Paenglab)

Tracking

({regression})

58 Branch
Thunderbird 60.0
x86
macOS

Thunderbird Tracking Flags

(thunderbird58 wontfix, thunderbird59 fixed, thunderbird60 fixed)

Details

Attachments

(5 attachments)

Posted image TB 59b1 French
It looks like bug 1155545 is back. Same configuration, but on macOS 10.13.3

I’ve been able to reproduce on 58b3, 59b1 and today’s Daily build.
iMac Retina display running macOS 10.13.3.
Confirming this bug for the French and German locales of TB 58.0b3, TB 59.0b1 and Daily builds.
Summary: Content in Preferences > Advanced is cut off → Content in Preferences > Advanced is cut off in mac Retina display
Version: unspecified → 58 Branch

Updated

a year ago
Flags: needinfo?(richard.marti)
(Assignee)

Comment 3

a year ago
When I ported the update functionality from FX to TB, I haven't checked if all makes sense.

This bites us now because some states don't need the update button. And especially this states use longer text which make together with the not needed button the prefs pane very wide.

When the Admin has disabled updates or an other instance does updates or updates are no more supported it makes no sense to show the check update button.

Tested fix on German and French builds.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #8951849 - Flags: review?(jorgk)

Comment 4

a year ago
I don't understand this bug very well. On Windows, the tabs of the advanced options are left-aligned and there is no cut-off.

I can't see any of the items adminDisabled, otherInstanceHandlingUpdates or unsupportedSystem, looks like there are hidden by code, but where? Will they ever be visible in TB?

I guess is doesn't hurt to remove disabled buttons of hidden items, but then, why not remove the entire item and any code referring to it.

Could you at least provide some screen shots?
(Assignee)

Comment 5

a year ago
Posted image widePrefs.png
The different items are in a deck. That means only one of them is shown and depending of the context the correct is shown. The deck uses the width of the widest item. The screenshot shows the widest item on French (and also German) TB. Removing the button "Rechercher des mises à jour" makes the whole deck fit again in the prefs window because this item uses then only the width of the text.

Comment 6

a year ago
Comment on attachment 8951849 [details] [diff] [review]
checkForUpdatesButton.patch

OK, I'm not 100% convinced that this is the best solution. It would be better to make sure the text is broken into multiple lines. I can imagine another language where this also won't fix even if you remove the buttons.
Attachment #8951849 - Flags: review?(jorgk) → review+
(Assignee)

Comment 7

a year ago
I tried it but didn't get line breaks. Probably because the have to be in <hbox>.
Keywords: checkin-needed
(Assignee)

Comment 8

a year ago
Comment on attachment 8951849 [details] [diff] [review]
checkForUpdatesButton.patch

It was found in beta and should also go to it to check if it's really fixed.
Attachment #8951849 - Flags: approval-comm-beta?

Updated

a year ago
Attachment #8951849 - Flags: approval-comm-beta? → approval-comm-beta+

Comment 9

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4e30bc0739dd
Remove unneeded checkForUpdatesButton in some cases in the Prefs Update pane. r=jorgk
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

a year ago
Target Milestone: --- → Thunderbird 60.0

Comment 11

9 months ago
I just found a similar issue for the "Chat" and "Kalendar" (Calendar) prefs panes in TB 60rc/build4
(macOS 10.13.6 on a iMac 21.5" Retina display)
You need to log in before you can comment on or make changes to this bug.