If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Some pages 'wrap around' into themselves

RESOLVED WORKSFORME

Status

()

Core
Layout
--
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: j13moh, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

After the page is loaded, I scroll down and at what should be the bottom of the
page, the rendering continues and you see the top of the page and you can scroll
through the whole page again.  In some cases, the page stops in the middle of
the rendering and then starts again from the start and is rendered all the way
to the end, it varies from site to site and happens 100% of the time of affected
sites.

I have noticed this since Mozilla 0.7 on both Linux, and Windows 2000 and
Windows 98.

Reproducible: Always
Steps to Reproduce:
1. Load the site shown above.
2. Notice that at the bottom of the page where it says "Copyright (C) Xteq
Systems - All Rights Reserved - Contact us at info@xteq.com" the page should be
done but if you scroll down, the page is rendered again below.

Actual Results:  The page was rendered twice so the bottom wrapped into the top.
 (The wrapping is not infinite, i.e. you cannot scroll down into infinity and
see the whole page.)

Expected Results:  The page should have been rendered once.

This happens on MANY pages and I will post more here when I encounter them. 
Then similarities in their code can be isolated.

On affected pages, if you click on a link in the "top" rendering, the window
jumps down to the same link in the "bottom" rendering as if it was an ' a
href="#link" ' type link.  If you click on the link in the bottom half, the
browser follows it as it should.
(Reporter)

Comment 1

16 years ago
Created attachment 83244 [details]
A screenshot to show exactly what it is meant by 'wrapping into self'

Comment 2

16 years ago
That page WFM, win98SE, RC2.
(Reporter)

Comment 3

16 years ago
That screenshot is actually Win2k with RC2.
(Reporter)

Comment 4

16 years ago
Apparently I was wrong in saying that this happens "every time" .

It happened here:
http://www.highschoolalumni.com/hsaweb/startpage.jsp?AffiliateID=465

But when I reloaded the page the effect disappeared.

Comment 5

16 years ago
I can't seem to reproduce under Windows Me using a newer build (2002-05-22-08).
Reporter, can you try with a newer nightly build ?

Comment 6

16 years ago
Marking WFM in the 2002-05-22-08 build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
I myself have seen this a couple of times with RC3.

The thing is that it does NOT happen every time, which contradicts what I
originally reported.  For example I just loaded http://www.xteq.com/ right now
and the page is fine.

The best I can say is that I cannot predict when or where it will happen.

If I am able to figure out any better explanation as to the cause I will report it.

Comment 8

16 years ago
*** Bug 150123 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
I'm re-opening this because of the dupe.  If it happens to more than one
installation, it's probably not one-off wierdness.  But since even the reporters
can't reproduce it, it's obviously pretty rare.

OK, we've got screenshots of this in both RC2 and 3.  Can either of you (j13moh
or kenbeal) see this in Moz 1.0 final, or a recent trunk build?  Any consistent
way to reproduce it?  
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 10

16 years ago
gavin long:

I just downloaded 1.0 final, and http://distcc.samba.org no longer displays
twice.  So I tried my other machine, which IS STILL 1.0 RC2! -- and it ALSO did
not display twice.  This was the SAME browser window which previously displayed
twice -- I just clicked the "Refresh" icon in the window that had it displayed
twice, and it came back displayed only once.

I don't know what could have changed overnight to make the behavior different. 
Perhaps this bug has something to do with caching proxies at different users'
ISPs?  Is there any way to test that theory?

Comment 11

16 years ago
Another page which displays doubled.  This one displays the entire page, then
repeats the top couple paragraphs at the end:

http://www.bustpatents.com/

This was with 1.0 RC3 in a Windows XP VM (VMware 3.1).

This site is also doubled in 1.0 final on Windows 2000 Server; it does not
repeat the same amount of information (one less paragraph), but it's still got
the first couple paragraphs repeated.
(Reporter)

Comment 12

16 years ago
I have http://distcc.samba.org loaded right now in another tab of Moz1.0 it is
is wrapping into itself *a little* but not totally.

I will post a screenshot shortly.
(Reporter)

Comment 13

16 years ago
Created attachment 86968 [details]
Sticthed Together screenshot from Moz1.0 (2002053012) showing this bug

After I took these screenshots, I shift+reloaded the page several times and the
problem did not appear on any of the iterations.

Comment 14

15 years ago
I can't seem to reproduce this issue in the July 1 build (2002-07-01-03) tested
under Windows ME.

Comment 15

15 years ago
I can not confirm any problem on any of the listed URIs with 
Mozilla/5.0 (Windows; U; Win98; de-DE; rv:1.1a+) Gecko/20020702
never saw this...still reproducable somewhere?

Comment 17

15 years ago
Marking wfm in the July 12th build (2002-07-12-08).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 18

15 years ago
I have seen this exactly zero times in 1.1alpha on win32 and linux.
You need to log in before you can comment on or make changes to this bug.