Closed Bug 1438349 Opened 2 years ago Closed 2 years ago

Disable credit card support for Form Autofill in Beta 59+

Categories

(Toolkit :: Form Autofill, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- disabled
firefox59 blocking verified
firefox60 --- verified

People

(Reporter: MattN, Assigned: MattN)

References

()

Details

Attachments

(1 file)

Since nobody is actively working on implementing the telemetry to track the quality of the feature and there are questions about storage, we should disable support for Credit Card Form Autofill in the beta channel. It will only remain enabled in Nightly.

Note that the credit card support would already not ride the trains to release 59 since it is guarded by an update channel check. This change is only about the beta channel.

The downside is that users who have already been using the feature in Beta 59 will lose it.

This plan was already discussed with Erin in https://trello.com/c/wfYJJKKx/452-form-autofill-v2#comment-5a723187b7b47b3bd6b03dc5
(In reply to Matthew N. [:MattN] (PM if requests are blocking you) from comment #0)
> The downside is that users who have already been using the feature in Beta
> 59 will lose it.

Will already stored credit card information removed? Or is it left on the profile indefinitely?
Comment on attachment 8951104 [details]
Bug 1438349 - Disable credit card support for Form Autofill in Beta 59+.

https://reviewboard.mozilla.org/r/220362/#review226334
Attachment #8951104 - Flags: review?(dolske) → review+
This is something we should uplift 59, tracking it as a blocker so can monitor it closely.
(In reply to Masatoshi Kimura [:emk] from comment #2)
> (In reply to Matthew N. [:MattN] (PM if requests are blocking you) from
> comment #0)
> > The downside is that users who have already been using the feature in Beta
> > 59 will lose it.
> 
> Will already stored credit card information removed?

No

> Or is it left on the profile indefinitely?

Yes, but this seems acceptable for a pre-release channel.
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/1ab257b6d0d9
Disable credit card support for Form Autofill in Beta 59+. r=Dolske
Comment on attachment 8951104 [details]
Bug 1438349 - Disable credit card support for Form Autofill in Beta 59+.

Approval Request Comment
[Feature/Bug causing the regression]: Form Autofill Credit Card support
[User impact if declined]: Beta users will continue to get credit card autofill even though we don't have telemetry to measure its effectiveness and it's not being actively maintined.
[Is this code covered by automated tests?]: Yes, all autofill tests will still run. I'm not sure how much coverage there is for tests with address autofill available but CC autofill unavailable though we have shipped in that configuration for a few releases before.
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: Probably can be done at the same time as bug 1438306 with a sanity check
[List of other uplifts needed for the feature/fix]: Bug 1438306 is related
[Is the change risky?]: No
[Why is the change risky/not risky?]: Disabling a feature with a pref that was intended for this purpose. There is a risk, likely small, of interfering with address autofill for en-US users in the US.
[String changes made/needed]: None
Attachment #8951104 - Flags: approval-mozilla-beta?
One thing I forgot to consider is the impact on Firefox Sync… I forget how the Sync engine becomes visible but ideally it would no longer be visible on beta. Mark, is there anything more than this patch that needs to be done for Sync?
Flags: needinfo?(markh)
That looks fine to me.
Flags: needinfo?(markh)
https://hg.mozilla.org/mozilla-central/rev/1ab257b6d0d9
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Verified credit card support using 59.0b10 and pref is set to "true", on what build/environment should we verify that the credit card support is disabled in 59?
Flags: needinfo?(MattN+bmo)
probably Windows 10 would be good enough once it lands on beta
Flags: needinfo?(MattN+bmo)
Comment on attachment 8951104 [details]
Bug 1438349 - Disable credit card support for Form Autofill in Beta 59+.

We're waiting to ship credit card autofill until we have more testing and support.
This should land for 59 beta 11, with the build next Monday and release Tuesday.
Attachment #8951104 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Backed out changeset 5a92ce6cddb6 (bug 1438349) for bc test failures on in-content/tests/browser_spotlight.js a=backout

Backout link: https://hg.mozilla.org/releases/mozilla-beta/rev/daeb05a6586b5c3ec5b7c4ba1a980f50e3620937

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=5a92ce6cddb6fd0ea65cdf26976d13f61229b23c

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=162990581&repo=mozilla-beta&lineNumber=5519

03:44:04     INFO - Leaving test bound test_address_autofill_section
03:44:04     INFO - Entering test bound test_credit_card_autofill_section
03:44:04     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_spotlight.js | Privacy pane is selected by default - 
03:44:04     INFO - TEST-PASS | browser/components/preferences/in-content/tests/browser_spotlight.js | The subcategory should be removed from the URI - 
03:44:04     INFO - Buffered messages finished
03:44:04     INFO - TEST-UNEXPECTED-FAIL | browser/components/preferences/in-content/tests/browser_spotlight.js | Uncaught exception - Wait for the credit-card-autofill section is spotlighted. - timed out after 50 tries.
Flags: needinfo?(MattN+bmo)
Following up in email since I'd like to land this for tomorrow's beta build if possible.
Flags: needinfo?(MattN+bmo)
Verified that credit card support is disabled in Fx 59.0b12 across all platforms, pref extensions.formautofill.creditCards.available;false.

Smoke tested autofill addresses and verified that credit card autofill is not visible with Sync enabled.
Verified that credit card support is disabled after Fx update.
Flags: qe-verify+
Requesting verification for Fx 60 beta as well.
Flags: qe-verify+
Verified that credit card autofill is disabled in 60.0b3 across all platforms, no issues encountered after update also.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.