Closed Bug 1438402 Opened 2 years ago Closed Last year

Intermittent browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | Test timed out -

Categories

(Firefox :: Site Identity and Permission Panels, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: johannh)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell fixed])

Attachments

(2 files, 1 obsolete file)

This bug has failed 74 time in the last 7 days on linx and osx platform on all build types.

Here is a recent log:
https://treeherder.mozilla.org/logviewer.html#?job_id=194131876&repo=mozilla-central

INFO - TEST-PASS | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | No MCB icon on HTTP page - 
[task 2018-08-15T18:44:05.004Z] 18:44:05     INFO - Buffered messages logged at 18:42:35
[task 2018-08-15T18:44:05.009Z] 18:44:05     INFO - Console message: [JavaScript Error: "this.chromeGlobal.content is null" {file: "resource:///modules/ContentLinkHandler.jsm" line: 463}]
[task 2018-08-15T18:44:05.011Z] 18:44:05     INFO - loadIcons@resource:///modules/ContentLinkHandler.jsm:463:9
[task 2018-08-15T18:44:05.012Z] 18:44:05     INFO - ContentLinkHandler/this.iconTask<@resource:///modules/ContentLinkHandler.jsm:459:44
[task 2018-08-15T18:44:05.012Z] 18:44:05     INFO - idleDispatch/</<@resource://gre/modules/PromiseUtils.jsm:40:21
[task 2018-08-15T18:44:05.013Z] 18:44:05     INFO - 
[task 2018-08-15T18:44:05.015Z] 18:44:05     INFO - Console message: [JavaScript Error: "Content Security Policy: Blocking insecure request ‘http://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.js’."]
[task 2018-08-15T18:44:05.016Z] 18:44:05     INFO - Console message: [JavaScript Error: "Content Security Policy: Blocking insecure request ‘http://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.js’."]
[task 2018-08-15T18:44:05.019Z] 18:44:05     INFO - Console message: [JavaScript Warning: "Loading failed for the <script> with source “http://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.js”." {file: "https://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.html" line: 9}]
[task 2018-08-15T18:44:05.020Z] 18:44:05     INFO - Buffered messages logged at 18:42:36
[task 2018-08-15T18:44:05.021Z] 18:44:05     INFO - Console message: [JavaScript Error: "this.chromeGlobal.content is null" {file: "resource:///modules/ContentLinkHandler.jsm" line: 463}]
[task 2018-08-15T18:44:05.024Z] 18:44:05     INFO - loadIcons@resource:///modules/ContentLinkHandler.jsm:463:9
[task 2018-08-15T18:44:05.025Z] 18:44:05     INFO - ContentLinkHandler/this.iconTask<@resource:///modules/ContentLinkHandler.jsm:459:44
[task 2018-08-15T18:44:05.026Z] 18:44:05     INFO - idleDispatch/</<@resource://gre/modules/PromiseUtils.jsm:40:21
[task 2018-08-15T18:44:05.027Z] 18:44:05     INFO - 
[task 2018-08-15T18:44:05.028Z] 18:44:05     INFO - Buffered messages finished
[task 2018-08-15T18:44:05.030Z] 18:44:05     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | Test timed out - 
[task 2018-08-15T18:44:05.032Z] 18:44:05     INFO - GECKO(1815) | MEMORY STAT | vsize 656MB | residentFast 269MB | heapAllocated 70MB
[task 2018-08-15T18:44:05.033Z] 18:44:05     INFO - TEST-OK | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | took 90064ms
[task 2018-08-15T18:44:05.036Z] 18:44:05     INFO - Not taking screenshot here: see the one that was previously logged
[task 2018-08-15T18:44:05.037Z] 18:44:05     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | Found a tab after previous test timed out: https://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.html - 
[task 2018-08-15T18:44:05.038Z] 18:44:05     INFO - GECKO(1815) | ++DOCSHELL 0xe9d0e000 == 1 [pid = 1988] [id = {ba5761ea-8ccd-4ed0-bdc6-0efc8b494557}]
[task 2018-08-15T18:44:05.039Z] 18:44:05     INFO - GECKO(1815) | ++DOMWINDOW == 1 (0xe9723160) [pid = 1988] [serial = 35] [outer = (nil)]
[task 2018-08-15T18:44:05.041Z] 18:44:05     INFO - checking window state
[task 2018-08-15T18:44:05.042Z] 18:44:05     INFO - GECKO(1815) | ++DOMWINDOW == 2 (0xe9d0ec00) [pid = 1988] [serial = 36] [outer = 0xe9723160]
[task 2018-08-15T18:44:05.100Z] 18:44:05     INFO - TEST-START | browser/base/content/test/siteIdentity/browser_identityBlock_focus.js
[task 2018-08-15T18:44:05.169Z] 18:44:05     INFO - GECKO(1815) | ++DOCSHELL 0xe9374c00 == 2 [pid = 1931] [id = {f41d5b33-91e2-4752-ae0a-a6c9acd2da09}]
[task 2018-08-15T18:44:05.172Z] 18:44:05     INFO - GECKO(1815) | ++DOMWINDOW == 3 (0xe9364040) [pid = 1931] [serial = 81] [outer = (nil)]
[task 2018-08-15T18:44:05.272Z] 18:44:05     INFO - GECKO(1815) | ++DOMWINDOW == 4 (0xe9376400) [pid = 1931] [serial = 82] [outer = 0xe9364040]
[task 2018-08-15T18:44:05.813Z] 18:44:05     INFO - GECKO(1815) | ++DOMWINDOW == 5 (0xe9378000) [pid = 1931] [serial = 83] [outer = 0xe9364040]
[task 2018-08-15T18:44:06.765Z] 18:44:06     INFO - GECKO(1815) | ++DOCSHELL 0xe8039400 == 2 [pid = 1961] [id = {950867d1-1977-46c5-9c34-cb7272984176}]
[task 2018-08-15T18:44:06.768Z] 18:44:06     INFO - GECKO(1815) | ++DOMWINDOW == 3 (0xe9335160) [pid = 1961] [serial = 103] [outer = (nil)]
[task 2018-08-15T18:44:06.868Z] 18:44:06     INFO - GECKO(1815) | ++DOMWINDOW == 4 (0xe803ac00) [pid = 1961] [serial = 104] [outer = 0xe9335160]
[task 2018-08-15T18:44:07.248Z] 18:44:07     INFO - GECKO(1815) | ++DOMWINDOW == 5 (0xe803c400) [pid = 1961] [serial = 105] [outer = 0xe9335160]
[task 2018-08-15T18:44:08.246Z] 18:44:08     INFO - GECKO(1815) | ++DOCSHELL 0xe9380800 == 3 [pid = 1931] [id = {839af5a1-5dba-44ac-93ce-6957a0de7815}]
[task 2018-08-15T18:44:08.248Z] 18:44:08     INFO - GECKO(1815) | ++DOMWINDOW == 6 (0xe93644c0) [pid = 1931] [serial = 84] [outer = (nil)]
[task 2018-08-15T18:44:08.324Z] 18:44:08     INFO - GECKO(1815) | ++DOMWINDOW == 7 (0xe9c06400) [pid = 1931] [serial = 85] [outer = 0xe93644c0]
[task 2018-08-15T18:44:08.380Z] 18:44:08     INFO - GECKO(1815) | ++DOMWINDOW == 8 (0xe937ac00) [pid = 1931] [serial = 86] [outer = 0xe93644c0]
[task 2018-08-15T18:44:09.051Z] 18:44:09     INFO - GECKO(1815) | MEMORY STAT | vsize 661MB | residentFast 277MB | heapAllocated 74MB
[task 2018-08-15T18:44:09.053Z] 18:44:09     INFO - TEST-OK | browser/base/content/test/siteIdentity/browser_identityBlock_focus.js | took 3957ms

:johannh Can you please take a look at this bug?
Flags: needinfo?(jhofmann)
Whiteboard: [stockwell needswork]
Attached patch Disabled on Linux and OSX (obsolete) — Splinter Review
Assignee: nobody → aiakab
Attachment #9001887 - Flags: review?(jmaher)
Comment on attachment 9001887 [details] [diff] [review]
Disabled on Linux and OSX

Review of attachment 9001887 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/test/siteIdentity/browser.ini
@@ +39,4 @@
>    file_bug1045809_1.html
>    file_bug1045809_2.html
>  [browser_csp_block_all_mixedcontent.js]
> +skip-if = (verify && debug && (os == 'mac')) || (os == 'linux') || (os == 'osx') # Bug 1438402

this needs to be os == 'mac', not osx.
Attachment #9001887 - Flags: review?(jmaher) → review-
Modified the diff
Attachment #9002015 - Flags: review?(jmaher)
Comment on attachment 9002015 [details] [diff] [review]
Disabled on linux and mac

Review of attachment 9002015 [details] [diff] [review]:
-----------------------------------------------------------------

looks good
Attachment #9002015 - Flags: review?(jmaher) → review+
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b721771cf97b
Disabled browser_csp_block_all_mixedcontent.js on linux and mac. r=jmaher
Keywords: checkin-needed
This bug failed 32 times in the last 7 days, they occur on windows10-64 on pgo and opt builds.

Log:
https://treeherder.mozilla.org/logviewer.html#?job_id=197900993&repo=autoland&lineNumber=3005

TEST-PASS | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | No MCB icon on HTTP page - 
19:06:15     INFO - Console message: [JavaScript Error: "Content Security Policy: Blocking insecure request ‘http://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.js’."]
19:06:15     INFO - Console message: [JavaScript Error: "Content Security Policy: Blocking insecure request ‘http://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.js’."]
19:06:15     INFO - Console message: [JavaScript Warning: "Loading failed for the <script> with source “http://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.js”." {file: "https://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.html" line: 9}]
19:06:15     INFO - Buffered messages finished
19:06:15     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | Test timed out - 
19:06:15     INFO - GECKO(6164) | MEMORY STAT | vsize 1748MB | vsizeMaxContiguous 131448591MB | residentFast 261MB | heapAllocated 90MB
19:06:15     INFO - TEST-OK | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | took 45035ms
19:06:15     INFO - Not taking screenshot here: see the one that was previously logged
19:06:15     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js | Found a tab after previous test timed out: https://example.com/browser/browser/base/content/test/siteIdentity/file_csp_block_all_mixedcontent.html - 
19:06:15     INFO - checking window state
19:06:15     INFO - TEST-START | browser/base/content/test/siteIdentity/browser_identityBlock_focus.js
19:06:16     INFO - GECKO(6164) | MEMORY STAT | vsize 1765MB | vsizeMaxContiguous 131448591MB | residentFast 277MB | heapAllocated 95MB
19:06:16     INFO - TEST-OK | browser/base/content/test/siteIdentity/browser_identityBlock_focus.js | took 1265ms
19:06:16     INFO - checking window state
19:06:16     INFO - TEST-START | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js
19:06:17     INFO - GECKO(6164) | JavaScript error: chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/head.js, line 180: ReferenceError: is is not defined
19:06:17     INFO - Not taking screenshot here: see the one that was previously logged
19:06:17     INFO - Buffered messages logged at 19:06:16
19:06:17     INFO - Entering test bound test_ClearSiteData
19:06:17     INFO - TEST-PASS | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js | Should have data for the base origin. - 61544 > 0 - 
19:06:17     INFO - TEST-PASS | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js | Should have data for the sub origin. - 61544 > 0 - 
19:06:17     INFO - Buffered messages logged at 19:06:17
19:06:17     INFO - TEST-PASS | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js | The clear data footer is not hidden. - 
19:06:17     INFO - Console message: [JavaScript Error: "ReferenceError: is is not defined" {file: "chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/head.js" line: 180}]
19:06:17     INFO - TEST-PASS | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js | Should have no data for the sub origin. - 
19:06:17     INFO - TEST-PASS | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js | The clear data footer is hidden after clearing data. - 
19:06:17     INFO - Buffered messages finished
19:06:17     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js | A promise chain failed to handle a rejection: is is not defined - stack: assertMixedContentBlockingState@chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/head.js:180:3
19:06:17     INFO - async*verifyUInotDegraded@chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js:22:9
19:06:17     INFO - promise callback*runTests@chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js:41:48
19:06:17     INFO - test/<@chrome://mochitests/content/browser/browser/base/content/test/siteIdentity/browser_csp_block_all_mixedcontent.js:53:18
19:06:17     INFO - _resolveAndCallOptionalCallback@chrome://mochikit/content/tests/SimpleTest/specialpowersAPI.js:1051:7
19:06:17     INFO - notify@resource://gre/modules/Timer.jsm:42:7
19:06:17     INFO - Rejection date: Thu Sep 06 2018 19:06:17 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
19:06:17     INFO - Stack trace:
19:06:17     INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
19:06:17     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1127
19:06:17     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1093
19:06:17     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:995
19:06:17     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
19:06:17     INFO - Leaving test bound test_ClearSiteData
19:06:17     INFO - Entering test bound test_ClearCookies
19:06:17     INFO - Console message: [JavaScript Warning: "“nsICookieManager.add()” is changed. Update your code and pass the correct originAttributes. Read more on MDN: https://developer.mozilla.org/docs/Mozilla/Tech/XPCOM/Reference/Interface/nsICookieManager2" {file: "resource://testing-common/SiteDataTestUtils.jsm" line: 65}]
19:06:17     INFO - Console message: [JavaScript Warning: "“nsICookieManager.add()” is changed. Update your code and pass the correct originAttributes. Read more on MDN: https://developer.mozilla.org/docs/Mozilla/Tech/XPCOM/Reference/Interface/nsICookieManager2" {file: "resource://testing-common/SiteDataTestUtils.jsm" line: 65}]
19:06:17     INFO - Console message: [JavaScript Warning: "“nsICookieManager.add()” is changed. Update your code and pass the correct originAttributes. Read more on MDN: https://developer.mozilla.org/docs/Mozilla/Tech/XPCOM/Reference/Interface/nsICookieManager2" {file: "resource://testing-common/SiteDataTestUtils.jsm" line: 65}]
19:06:18     INFO - TEST-PASS | browser/base/content/test/siteIdentity/browser_identityPopup_clearSiteData.js | The clear data footer is not hidden. - 

:johannh: Can you please take a look at this bug?
Whiteboard: [stockwell disabled] → [stockwell disabled][stockwell needswork]
Assignee: aiakab → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Priority: P5 → P3
Comment on attachment 9007721 [details]
Bug 1438402 - Fix intermittent browser_csp_block_all_mixedcontent.js. r=nhnt11

Nihanth Subramanya [:nhnt11] has approved the revision.
Attachment #9007721 - Flags: review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/402f26a30b2d
Fix intermittent browser_csp_block_all_mixedcontent.js. r=nhnt11
Keywords: leave-open
https://hg.mozilla.org/mozilla-central/rev/402f26a30b2d
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Duplicate of this bug: 1490482
https://hg.mozilla.org/releases/mozilla-beta/rev/2dec8bceca01
Flags: in-testsuite+
Whiteboard: [stockwell disabled][stockwell needswork] → [stockwell fixed]
Blocks: 1516689
You need to log in before you can comment on or make changes to this bug.