do not prefetch files when saving

VERIFIED DUPLICATE of bug 129923

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 129923
16 years ago
2 years ago

People

(Reporter: johann.petrak@gmail.com, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Prefetching files to a temporary location while the save dialog comes up
might look like a good idea, but it causes so many problems that the 
disadvantages by far outweigh the advantages:

- prefetching does not what a user expects: what is expected is that
  the file will get retrieved to the specified location, and that the
  progress of the download can be monitored by looking at the growing
  file, and that the
  file will not be accessed when the download is canceled.
- if the disk space where the temporary file gets stored is too small
  the download will fail
- if the temp directory is not accessible the download will fail
- if the file is big, moving it from the temp direcotry to the final
  location will take a long time
- if the disk space of the destination path is too small, the download
  will fail only after too much has already been downloaded
- if mozilla crashes the temporary download file is hidden somewhere
  in the temp dir under a strange name
- if the user downloads a huge file, it is not possible for him to 
  view it while the download is going on to decide whether to continue
  (e.g. sound or video files)
- since one temporary download directory will be used for many users,
  the space problem gets worse. Also, file permissions might allow
  other users to get undesired information about downloads.

Comment 1

16 years ago
The issues listed here are already logged under bug 129923, bug 55690, and their
(many) dependencies.

*** This bug has been marked as a duplicate of 129923 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
I dont think this is a DUP, since none of these bugs explicitly
ask to abandon prefetching, and instead just try to fix *some* of the
many issues. However, some of the problems simply *cannot* be fixed 
without giving up prefetching, and the rest will take forever to fix.
So this bug asks to not do prefetching, since it massively breaks things. 
johann, please read bug 55690 (whose summary has been changed and is now
misleading).  "abandoning prefetching" completely is simply not an option; the
only reasonable possibility is to prefetch very slowly and into RAM instead of
to disk....
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
Thanks, got misled by the desc. 
BTW a request to *do* prefetching has been marked "wontfix"
in 22796 :)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.