Clicking on the location in browser console with new frontend throws

RESOLVED FIXED in Firefox 60

Status

defect
P1
normal
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: nchevobbe, Assigned: nchevobbe)

Tracking

Trunk
Firefox 60

Firefox Tracking Flags

(firefox60 fixed)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 attachment)

**Steps to reproduce**
1. Open the browser console
2. Click on a random location link


**Expected results**

The old frontend used to open the raw file in a new tab

**Actual results**


There's an error thrown: 
```
TypeError: onClick is not a function Frame.js:223:11
```

---

Looks like we don't set up onClick well in the case of the browser console.
Assignee

Updated

a year ago
Priority: -- → P2
Whiteboard: [newconsole-mvp]
Assignee

Updated

a year ago
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment hidden (mozreview-request)
Assignee

Comment 2

a year ago
mozreview-review
Comment on attachment 8952103 [details]
Bug 1438463 - Fix click on location in browser console with new frontend; .

https://reviewboard.mozilla.org/r/221326/#review227186
Attachment #8952103 - Flags: review+

Comment 3

a year ago
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/43390eee8142
Fix click on location in browser console with new frontend; r=nchevobbe.
Assignee

Comment 4

a year ago
OOOps, mistook this patch for another one (even r+d it because I thought mozreview wasn't working …), let's have another coffee.
Also, I still want you to review the patch, and if you have comments I'll address them in a follow-up.

Comment 5

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/43390eee8142
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60

Updated

a year ago
Product: Firefox → DevTools
Assignee

Comment 6

10 months ago
Comment on attachment 8952103 [details]
Bug 1438463 - Fix click on location in browser console with new frontend; .

clearing flag since this already landed quite some time ago
Attachment #8952103 - Flags: review?(bgrinstead)
You need to log in before you can comment on or make changes to this bug.